Alfa Romeo Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
Hi all,

I wonder if you could please help?

I've recently found a light brown silicon liquid sitting in my coolant tank and seem to be filling up the coolant tank on a weekly basis and experiencing overheating issues. I reported this to the alfa garage on various occasions but they just don't seem interested.

I've taken samples of the stuff and the cars booked in on saturday but would appreciate some advice prior dropping the car off.

Any ideas?

:)
 

·
Registered
Joined
·
9,178 Posts
Could it be oil? It might be the oil filter heat exchanger is split inside and oil is getting pulled into the water system.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #5
I'm thinking definitely oil.

Thanks for the comments. I will mention it when I take the car down on Saturday.

Cheers
:)
 

·
Registered
Joined
·
18 Posts
Discussion Starter #6
The cars only had an engine rebuild by alfa 1000 at 38,000miles (now 39,500!!).

Now i realise why they keep so quiet when I mention it to them. :)
 

·
Registered
Joined
·
30,018 Posts
The oil/water heat exchanger is a known failure point that results in oil filling the coolant tank.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #9
insisted on a 12 month unlimited warranty when buying so shoudn't be any issues there.

Do you think the oil/water heat exchanger failure could screw up the radiator as well?

The engine is running hot and I haven't heard the fan kick in once since purchasing.
 

·
Registered
Joined
·
92 Posts
It sounds more like the head gasket has blown if the temperature is high. What was involved in the rebuild and why was it needed?
 

·
Registered
Joined
·
18 Posts
Discussion Starter #13
Rebuild

Remove and repair cylinder head
Rebuild with new cam belt kit

Parts
Inlet Valves x8 £120
ExH Valves x8 £114
Head Set £90
Belt Kit £118
Head Repairs £90
Labour £500

Total £1200 ish.!!
 

·
Registered
Joined
·
18 Posts
Discussion Starter #14
The cars been dropped off now with Alfa so fingers x'd it will just be the oil/water heat exchanger.

Will keep you posted.
 

·
Registered
Joined
·
9,178 Posts
If it turns out to be the head gasket, chances are they either failed to check the head on a straight edge and it's slightly warped or they stuck a 2nd-hand head on with the same problem. BTW a new heat exchanger isn't cheap!
 

·
Registered
Joined
·
18 Posts
Discussion Starter #16
gazza82.

You were correct. Head Gasket had gone.

I picked the car up today and have to say that it seems like I'm driving another car performance wise.

Will keep an eye on things over the next couple of weeks. Fingers x I will have a trouble free summer. :rolleyes: :lol:

Cheers
1st-alfa2009
 
1 - 16 of 16 Posts
Top