Alfa Romeo Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
114 Posts
Discussion Starter #1
:( drove my baby back from colchester on tuesday, dropped m8 off and he said sumfin that i didnt relly want to hear... he said my baby sounded like a diesel :mad: so with that comment bouncin bout in me ead i drove home... let her cool down then checked oil.... oils fine so started her up and ugh.... a rather "money burnin" knock from top of belt cover... variator,cambelts and tensioners replaced @ 96000, car has been meticliously looked after by former owner with oil and filter changes every 7000 miles... dash now showin 111000.... ive carried on the oil and filter change .... any ideas people??? :confused: does it sound terminal? should i break the bi**h? who wants my mirrors?? :D
 

·
Registered
Joined
·
5,093 Posts
i know nothing about alfa romeo's :eek:
sorry mate im useless
i only brought mine coz i liked the look of it
if i hadn't got the 155 i'd prob be in the toyota supra forum right now :cheese: :cheese: it was lower price car and 2 trips to thailand or supra :cheese:
 

·
Registered
Joined
·
114 Posts
Discussion Starter #6
AlfaJack said:
Sounds exactly like the variator, They said they changed it but DID they, you never know :confused:
mmm thats the trouble init ..... might look into gettin it changed ... is it terminal,shaould i be worried bout it.. cause like phil my first alfa was brought on impulse... but my second 1 was out of love :D but still much like my computter illeteratcy im the same with cars?? :cheese:
 
P

·
Guest
Joined
·
0 Posts
the variator should only make a noise on startup for about 1-2 seconds when it is faulty.

Is your car making that sound all the time?
 

·
Registered
Joined
·
2,425 Posts
It might not be the Variator itself but the oil supply that makes it work.

I know you've checked the oil level but there could be a partial blockage somewhere in the oil-way or the controller (solenoid?) for the variator. Have you tried the trick of adding the Bardahl, engine de-gunker or Wynns cleaner? Might be worth a try. Black Beauty's thread on the subject.

http://www.alfaowner.com/Forum/showthread.php?t=34943&highlight=wynns
 
W

·
Guest
Joined
·
0 Posts
Pascs said:
the variator should only make a noise on startup for about 1-2 seconds when it is faulty.
Err, no. When in the more advanced state of failure it will rattle ALL the time, at tickover or when revved, hot or cold.

A lot of the Twinsparks rattle a bit for the few couple of seconds anyway, untilt the oil circulates.

wrinx
 
W

·
Guest
Joined
·
0 Posts
champers155owner said:
... is it terminal,shaould i be worried bout it..
No, it's not terminal but until you confirm it is in fact the variator I would drive straight to a garage and get it checked.

wrinx
 

·
Registered
Joined
·
114 Posts
Discussion Starter #13
Sunbar said:
It might not be the Variator itself but the oil supply that makes it work.

I know you've checked the oil level but there could be a partial blockage somewhere in the oil-way or the controller (solenoid?) for the variator. Have you tried the trick of adding the Bardahl, engine de-gunker or Wynns cleaner? Might be worth a try. Black Beauty's thread on the subject.

http://www.alfaowner.com/Forum/showthread.php?t=34943&highlight=wynns
hopefully i aint got a blockage... engine was only degunked bout 6000 miles ago at last oil/filter change... gettin bit worried now but hopefully alfa man will point me in the right direction :rolleyes:
 

·
Registered
Joined
·
114 Posts
Discussion Starter #14
right ppl....... been to see the trusted alfa man... my variator is on its way... booked in for next week £200 ouch but gonna be so worth it i hope :D just not needed at this time of year but hey... we r used to it.... typical i suppose.. ani way tx to all that helped.. :D :D :D :D :D :D
 

·
Registered
Joined
·
6,920 Posts
£200! not bad but I expect that is just the variator, maybe worth digging deep now and getting all belts and tensioners done
 

·
Registered
Joined
·
114 Posts
Discussion Starter #16
AlfaJack said:
£200! not bad but I expect that is just the variator, maybe worth digging deep now and getting all belts and tensioners done
according to service history jack all belts,tensioners and variator where replaced only bout 18000 ago :rolleyes: didnt really wanna stretch and ave belts done too :mad: alfa man says it should be ok just doin variator... i trust him for now :cheese: well as much as u can trust a mech.... but he aint greedy as i suppose he wood ave said i needed them doin too... :eek: he done all the work on my old baby (33) and i had some major probs with that and he was the man :D just wish there was more like him.... mite even send his arse a crizzy card.. :)
 

·
Registered
Joined
·
4 Posts
Took variator off and put 12v feed to it and it worked.
It still knocks when in the engine and running though sounds like a diesel. Is this because of the oil feed may be blocked?
 
1 - 18 of 18 Posts
Top