Alfa Romeo Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
148 Posts
Discussion Starter #1 (Edited)
My 156 2L JTS has developed a chirp ONLY AT IDLE after I had been banging around trying to stop the catalytic convertor heat shield from rattling. This may or may not be a coincidence but it is making me feel awful.

I believe the chirp is either coming from the cam, aux belt, sump, exhaust or catalytic convertor. The chirp is most intense rear of the cat around the sump.

I know one cat is on the way out courtesy of fiatECUscan and a rattling muffler. The cam belt was changed 5000km ago by the dealer but I am uncertain whether they replaced the tensioner or knew what they were doing.

Any advice or insight would be much appreciated as my car is meant to be used as a bridesmaid’s car in my friend’s wedding in 4 days.:(

I really want to know if anyone has had crank case bearings squeal only at idle.
 

·
Registered
Joined
·
148 Posts
Discussion Starter #2
Also it takes about 20 seconds from start up for the noise to develop and the car drives fine.
 
L

·
Guest
Joined
·
0 Posts
have you looked at the mounting brackets for the exhaust? they could be partially cracked or fully broken
 

·
Registered
Joined
·
148 Posts
Discussion Starter #4
Thanks, I will put that on today’s to do list. I have had that bracket off before (the one just before the flexi section) to repair the bushing; potentially I could have broken it whilst moving the exhaust around.

I tried dampening that area with my hands yesterday, with gloves on of course but it didn't have any effect but then again it doesn't take much movement for annoying noises to be created.
 

·
Registered
Joined
·
148 Posts
Discussion Starter #5
Found it!

All I need to do is turn the air conditioning on. The ac clutch is generating the noise.

Now how do I fix it?
 
1 - 5 of 5 Posts
Top