Alfa Romeo Forum banner
1 - 4 of 4 Posts

·
Registered
Brera '08 JTDM SV
Joined
·
267 Posts
Discussion Starter · #1 ·
Wife returned from shops to inform me that the low battery warning was on and the stearing very heavy. It looks as though the fan belt has lost its tension but I can see why or how to adjust. The alternator is at the back and down low. Is there an easy way of getting to it or is it undertray off? I'm assuming the adjustment is on the alternator?

Any help ASAP much appreciated as I have to fix tonight.
 

·
Registered
Joined
·
12,881 Posts
Just to be pedantic ... it's not the fan belt (as it isn't attached to the fan :D) ... it's the auxiliary/alternator belt, but it sounds like the belt tensioner has broken ...
 

·
Registered
Brera '08 JTDM SV
Joined
·
267 Posts
Discussion Starter · #3 ·
Chris,

I'm far too old for these new fangled terms!

You are however right, I found the tensioner and its unhappy.

And so am I, the dammed thing is supposed to be taking me and the race car down to Goodwood tomorrow lunchtime.
How are you on flying pigs?
 

·
Registered
Joined
·
12,881 Posts
How about a combination of WD40 and cable ties???? I've heard of a JTD running for 200 miles with a snapped alternator belt ... I suppose it's because once the car is started it doesn't need a spark to keep it going ... all that is needed is to run the ECU and some "ancillary bits" so it all depends on how far you need to travel ... or just buy a new battery every 100 miles or so ...
 
1 - 4 of 4 Posts
Top