Alfa Romeo Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1,155 Posts
Discussion Starter · #1 · (Edited)
I've broke it!! no brakes

Driving home from town this afternoon and the pedal goes to the floor!!

Master cylinder is empty!!!

Checked all the lines and one of the rears is weeping so took it off cleaned and refitted!!!

Filled the mc with fluid tried to bleed it thru and had no pedal at all!!!

Got a bit of air out of the nipples but still no pedal feel!

Have pumped 2 litres of fluid thru and still no pedal, spoke to a mechanic friend who said to open the unions at ABS pump and master cylinder and try and get any air from there.

Have got some out of the unions and now have a firm pedal when the engine is off and a better pedal when running but there is still alot of travel.

Want to bleed the mc properly but how do you get to slacken off the rearmost banjo bolt?
 

·
Registered
Joined
·
1,155 Posts
Discussion Starter · #2 ·
Any one??

Have rebled this morning and got a bit more air out of the mc, haven taken it for a drive the brakes now work and stop the car from 70 but the peddle is really long!!
 

·
Registered
Joined
·
1,155 Posts
Discussion Starter · #7 ·
Well I have managed to get it tiny old mans, he has some fancy bleed kit that forces the fluid in via gravity and sucks it out at the same time.

So first i have just used my halfords trade card and purchased 5 liter of fluid!!!

Will get this sorted today!!

Still can't see how to get on to the rear master cylinder outlet to try and bleed it from there!!!
 

·
Registered
Joined
·
1,155 Posts
Discussion Starter · #10 ·
All sorted

Used a pressure bleed on the master cylinder and a suction pump on the nipples!!

Pedal is now rock solid with plenty of bite

Now on to the next problem
How the hell do you get to oil filter!
And how do you get a mullerd sump bolt out?
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top