Alfa Romeo Forum banner

1 - 20 of 34 Posts

·
Registered
Joined
·
3,213 Posts
Discussion Starter · #1 ·
ok so my dead spider is now up and running....just! woohoo!:)


Thank you to everyone who advised me on what to do :thumbs: as i had never changed a car tyre before i had my spider :wow:and now im still a novice dont get me wrong, but a better educated novice who has enjoyed tinkering. :cheese: i've had five cars before my spider and i havent ever lost sleep over one, and never missed driving a car so bad! the worst was when it was sunny and my poor spider all still in the drive and a soft top drove past :cry:.......sometime you dont realise what you got till its gone!

But it back! well sort off?

so new gasket seal, new battery, changed oil, cleaned ht leads, plugs and wells (blew wells as advised) checked cam belt no teeth missing etc and it now starts first time but..........................its now a smokey tractor :confused:.....................the plot thickens??????

check out the vids, now im confused? :confused:

YouTube - alfa spider noise?
YouTube - alfa spider noise smoke 1
YouTube - 100 2632
 

·
Registered
Joined
·
2,077 Posts
The smoke looks like oil burning off the pipes as they heat up, the noise sounds like top end, i hate to say this but your cambelt may have slipped, thats probably going to be a new top end at least, thats my best guess though.
 

·
Registered
Joined
·
2,077 Posts
surprised nobody else has replied so bumped it back to the top, alfa owner needs advice people.
ps i had a cambelt slip on a mazda 626, it ran thereafter but was way down on power, the battery although fully charged struggled to turn the engine when starting, wasnt as mechanically noisy as yours though as far as i can remember.
dropped valve is another possibility?
Ebay is a good place to look, at least one company on there doing rebuilt engines quite cheaply. best to get a professional opinion first though.
 

·
Registered
Joined
·
2,877 Posts
blimey, its not happy is it :(

Wouldnt worry too much about the smoke at this point as thats probably just excess oil burning off - had that on my 2-stroke lawnmower a few times, made an impressive smoke screen :)

However that top ends sounds buggered.
 

·
Registered
Joined
·
2,077 Posts
are there any timing marks on the pully wheels to check if the belts slipped and the timings is out? thanks jon
:)
There will i am sure be timing marks, sorry never played with cambelts so cant advise how to check, there are several people on the forum that can though, maybe start another thread headed "how do i check timing marks".
 

·
Registered
Joined
·
8,918 Posts

·
Registered
Joined
·
1,843 Posts
The timing marks wont be alot of use as they are only used to line up with marks on the belt when new. i suspect the belt marks will be long gone. Cam locks is the only way. Easy to do if you can get hold of some, you can borrow mine but I am in Kent. You can see how to use them here.

http://www.alfaowner.com/Forum/motoring-images/168718-my-new-project-6.html
Mitch, am I right in suggesting that he could whip off the cover, turn the engine until one cam lock fits and then see if the other will sit in place?

That would be a way of checking without any serious work?

On another note...can you send me some photos of your interior Jon? I have just sanded all that horrible rubbery stuff off my centre console and yours looks nice!
 

·
Registered
Joined
·
491 Posts
The best way is to find tdc just take a plug out and put a screwdriver down onto no 1 piston (if you dont have a dial guage) once you are at the top of the cycle then try and fit the cam locks onto the relevent cam lobes if the both fit perfectly then the belt has not slipped.
 

·
Registered
Joined
·
8,918 Posts
Mitch, am I right in suggesting that he could whip off the cover, turn the engine until one cam lock fits and then see if the other will sit in place?

That would be a way of checking without any serious work?

On another note...can you send me some photos of your interior Jon? I have just sanded all that horrible rubbery stuff off my centre console and yours looks nice!
Thats exactly what he needs to do.

I also refirbed the centre console, it came out really well, see here.

http://www.alfaowner.com/Forum/motoring-images/168718-my-new-project-9.html
 

·
Registered
Joined
·
3,213 Posts
Discussion Starter · #12 ·
turtle4288 i just finish the interior and then this happened:cry: anyway i will get my finished pics taken and upload and post on sunday:cool:
 

·
Registered
Joined
·
1,843 Posts

·
Registered
Joined
·
2,569 Posts
Seats look excellent buy, but Jon you need to get someone to look at the engine, it sounds bad. I wouldn't run it again until youv'e got someone to look at it. If it is the cam belt that has slipped your tentioner has probably had it and next time one of the teeth might get chewed up and then even more damaged to the engine:cry:. Have a look on here for a recommened indie near you.. good luck.
 

·
Registered
Joined
·
384 Posts
I take it that the noise the cam variator makes when it's gone is not as bad as this????

You were leaking a lot of oil, have you checked the level/condition?

Best get it to a good indie (on a trailer) with diagnostics, they should find out very quickly once its connected up.

My partner had the timing belt slip on a Honda (only one tooth), took it to an indie and they couldnt diagnose the problem in 5 hours!!, took it to the dealer and they diagnosed it in 1 minute once hooked up. It didnt sound like that though.

Good luck
 
G

·
Broken exhaust manifold sounds a bit like that.
On first start of my a series mini engine I had the manifold off and it sounded very similar. Would explain the smoke too. Although there seems to be quite a bit of blue smoke in the last video

Does the engine rev without any problems??
 

·
Registered
Joined
·
1,577 Posts
Doesnt sound very happy! I`m struggling to connect all the different failures together though,, very odd. Life is never dull with an Alfa Romeo :D
 

·
Registered
Joined
·
1,843 Posts
Broken exhaust manifold sounds a bit like that.
On first start of my a series mini engine I had the manifold off and it sounded very similar. Would explain the smoke too. Although there seems to be quite a bit of blue smoke in the last video

Does the engine rev without any problems??
+1! Yes try revving the nuts off it, whats the worst that can happen?

I also rekon its not the timing belt. Have you double checked all the plugs are tight?
 
1 - 20 of 34 Posts
Top