Alfa Romeo Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
54 Posts
Discussion Starter #1
Help! My 156 is very poorly. It's a 1.8 W reg. Variator is very noisy, not sure whether to drive it or plough with it, then it started only running on 3. A bit of investigation revealed cylinder number 4 not firing. Today cylinder 3 gave up the ghost. I've had the plugs out and they were pretty caked up so have changed them. Also changed coils and injectors for used but definitely working ones. Made no difference. Makes a jingling noise so think maybe the cat has gone? Any ideas? Thanks Steve.
 

·
Registered
Joined
·
11,604 Posts
When was the timing gear replaced?
 

·
Registered
Joined
·
3,269 Posts
I think a knackered variator just makes it sound rough and will leave you down on power at higher revs. Although it's not ideal running with it like that, I don't think it should do any particular harm to the engine.
 

·
Vendor
Joined
·
45,826 Posts
Need to do a compression test I reckon.
 

·
Registered
Joined
·
54 Posts
Discussion Starter #6
Thanks for the advice peeps.

Well took it over to see Justin at QSP, compression test confirmed that cylinders 3&4 have no compression, at all, not even reading on the gauge, so either head gasket or valves either way head gotta come off.:cry:

Booked in for pre mot as it's due end of Feb, if its worth moting then i'll get the head done if not................... I think it'll be ok but we'll see what Friday brings:confused:

Trying to stay positive:thumbs:
 
1 - 6 of 6 Posts
Top