Alfa Romeo Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1,699 Posts
Discussion Starter #1
Hi all,

Have tried for almost six months to get the air con set up so I'm happy with it, but it's either not a very good setup or it's broken.

All with air con switched on:

What happens on auto when cold is it turns the fan down to speed 1 and puts a trickle of air in the cabin. With a setpoint of 21'c on the dial, I would have thought it would give max heat - but it will blow hotter if you turn the dial to max hot and take it off auto.

If left set on 21'c auto after a mile or two, when it warms up it suddenly puts the blowers on max - which can scare the crap out of you when driving home after a night shift! It then blasts you with all the fury of Hell itself until you are barbecued. Then it realises it's got too hot and winds the heat right back until you're cold.

If you select max defrost, it sticks the heated rear window on (which it should do) but if the car is cold, it puts only a trickle of air on the windscreen - once again you can make it work better by putting the heat on max, the fan on 4 and aiming it at the screen.

It really is more effective to do it all yourself, which kind of defeats the object of having climate control. I've cleaned out the dust etc. from the cabin temp sensor in the dash, but that has made no difference.

Am I expecting too much from me poor old vee-hickle? :confused:
 

·
Registered
Joined
·
396 Posts
Sounds like its working as it should albeit not very well. If you leave it on auto it always correcting itself because its trying to keep at the set temp, if you set the fan speed manualy it just keeps heating.
I usually keep fan speed on 2 with temp at 21 in winter and it seems ok.
In the summer i have temp dial set at around 17-18 but leave fan speed on zero, for some reason this seems to work great for cooling.
 

·
Registered
Joined
·
30,200 Posts
Yep sounds normal.
With the fans on "auto" they will not blow much until there is some temperature in the engine.
 

·
Registered
Joined
·
1,699 Posts
Discussion Starter #4
Thanks for the replies, fellas. I'd imagined I could just set it and leave it!

At least I know it's not just me then :D
 
1 - 4 of 4 Posts
Top