Alfa Romeo Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
822 Posts
Discussion Starter #1
Help just got my ipod link cable from Alfa and it isent recognised by the radio, well it wont play anyway. The ipod itself comes up with the Alfa logo but iI cant select the Ipod on the radio. Anybody had a similer problem or got any ideas:rant:
thanks in advance Tony
 

·
Registered
Joined
·
25,673 Posts
First thing to check is that your iPod's firmware is compatible with the cable and interface.

If not update it, the latest version of iTunes downloads and updates your pod without having to download anything else.

Hope you get it running, it's great.

:)
 

·
Registered
Joined
·
822 Posts
Discussion Starter #3
the ipod is fully up to date as its only a month old. Is it possible the radios age has somthing to do with it as well?
 

·
Registered
Joined
·
1,433 Posts
is the cable that goes into the cd changer socket on the back of the headunit seated correctly? How old is your 147? i fitted the kit to my 2003 147 just a few weeks ago with no problems.
 

·
Registered
Joined
·
821 Posts
You need to select the DVD changer, it will then take the first ten playlists on your iPod (alphanumerically) as being the CDs 1-10 of your virtual CD changer.

Hope this helps? ;)
 

·
Registered
Joined
·
822 Posts
Discussion Starter #7
I cant get it to select the changer. pressing the src button it gose from fm-lw-no ca-fm-lw no hint of a cd changer :cry:
 

·
Registered
Joined
·
822 Posts
Discussion Starter #8
Sorted it now, dont know what I actually did but I did it :cheese: . Thanks for the replys;)
 

·
Registered
Joined
·
821 Posts
Good to hear (sic!) :lol:

Enjoy the music
 

·
Administrator
Joined
·
87,603 Posts
What exactly is the Ipod link cable and where did you get it (part no.), does it just allow you to connect Ipod to radio or does it also power Ipod ? I got one of the blaupunkt cables from bluespot but it didn't work for me
 

·
Registered
Joined
·
821 Posts
Mine is the proper Alfa kit, which I had fitted by the dealer. Cable runs into the glove box, you plug the iPod in and the head unit thinks its the CD changer, so you can use the main controls for the H/U. It does power the iPod also.

;)
 

·
Registered
Joined
·
822 Posts
Discussion Starter #12
David P said:
What exactly is the Ipod link cable and where did you get it (part no.), does it just allow you to connect Ipod to radio or does it also power Ipod ? I got one of the blaupunkt cables from bluespot but it didn't work for me
The one I have is from Alfa aswell, I had it on order for 2 months:rant: , but its here now and its working fine.
Just go in and ask for the ipod link cable or they do come up on ebay now and then
 

·
Registered
Joined
·
592 Posts
Aaargh!!!

My iPod thinkgy link cable wont work either!

I got mine from Blaupunkt not Alfa. It works to some extent that it will pick up the playlists - but if you try and move through the place list it gets stuck on tracks one and two.

Does a few funky other things as well and there is sometimes a high pitched whine in the background.

Anyone else seen similar?

Ipod is on latest firmware and blaupunkt unit has been updated too.

I wonder if there is specific firmware for the Alfa head units?

D
 

·
Registered
Joined
·
592 Posts
Awwwwwwwwwww bugger!!!

Just spoke to a nice guy at Blaupunkt and it seems the only ipod interfaces that are compatible with Alfa GT head units are the ones you buy from Alfa.

So the one I have is useless!!!

:rant:

Plus Alfa won't hand over the firmware to Blaupunkt either. The hardware is identical.

Poo.

Anybody want to buy a semi working iPod interface? :D

Seems ill buy one from the dealer then. :-(

D
 
1 - 15 of 15 Posts
Top