Alfa Romeo Forum banner
1 - 3 of 3 Posts

·
Registered
'08 Brera S 2.2 (Edition no 45). Previously '12 Mito 1.6 JTDM
Joined
·
416 Posts
Discussion Starter · #1 ·
Towards the end of last year my 2008 Brera S (2.2 c.110k miles at the time) had a slight squeaking noise from the suspension and the steering felt disconcertingly loose around the straight ahead. Lower suspension arms were replaced which stopped all noise and the steering felt better. Upper arms were checked but there was no play.

Now a few months and c.6k miles later the steering does not feel good again - loose around the straight ahead, needing constant small corrections and thrown off by mid-corner bumps, sometimes quite large movements in the steering wheel.

Following a 6 hour drive over the weekend on some pretty poor A roads (A83 in the pouring rain so difficult to spot the many large craters) there is a very loud noise from the front nearside suspension - particularly noticeable around 10-20mph over bumps. Sounds very creaky/almost plasticky.

The odd thing is that both things are not constant - on my morning commute one day it'll be creaking and loose steering then other days it'll be silent and the steering will feel tight and responsive.

I'm guessing upper arm bushes and possibly rod-ends given the mileage should be the first things to check but thought I'd see if anyone has experienced similar and has other things to look for, and also any ideas why the symptoms come and go?

Will be getting it checked over soon.
 

·
Registered
Joined
·
3,031 Posts
The upper arm inner bushes behave like this. Dirt and grit get in and move about which changes the noise. So replace then with standard rubber inserts (forget the plastic replacements that some have fitted with grease nipples)

But your comments about a strange feeling to the steering sounds more like a seizing steering knuckle. So worth getting those checked.
 

·
Registered
'08 Brera S 2.2 (Edition no 45). Previously '12 Mito 1.6 JTDM
Joined
·
416 Posts
Discussion Starter · #3 ·
Thanks, strangely the steering has been fine since I posted but the squeak is constant now. It was incredibly wet on the long drive so maybe moisture has moved grit?
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top