Alfa Romeo Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter #1
Hello! Nice to see that there are people who love Alfa's so much and willing to help! :)

My problem is with interior lightning, when opening door everything is OK, it turns on, both, front and back and stays on for few seconds when the door is closed. But I cannot turn on the back interior lights when the doors are closed. When I push the switch nothing happens, just when pushed ones it wont work when the doors are opened. Is this normal? Also the passenger light behind the sun visor doesn't work, no 12 v supply at all.

I have never owned an Alfa, only Fiat, which was a very good car. Now I am an owner of 156 1.8 TS 1998, which was my brother's, who died a month ago in a motorcycle accident.

I have much work to do on my Alfa, camshaft sensor is toast, front left lower arm needs changing, radiator fan relay stopped and the car overheated and blew a gasket, changed but cheap oil was put so oil and filter change, radiator already bought and needs changing, CNG conversion, front lights and some other smaller repairs. The only good thing about this is that I have a friend with all the tools and a garage so I can change it by myself.
 

·
Registered
Joined
·
2,271 Posts
My interior lights are also haunted! I have a newer face lift car with 2 spots up front, 2 lights in the visors and 2 lights in the back. Don't know if your car is the same. Each spot has 3 switch settings. All bulbs appear to work but not in a logical way that I understand. One day I'll get round to finishing reading the owners manual but I gave up on the dual zone climate control chapter. The answer maybe in there!
 

·
Registered
Joined
·
58 Posts
Discussion Starter #4
The ones above the visor only work with the ignition on. The master is on the passenger side spot.
This is kind of stupid, isn't it? Only with the ignition on? Can you send me the owners manual, I will try to get the info that we need. :) I also have Renault 19, two lights in front, two on the back, all work without ignition, switches for turn on and off. Why haven't Alfa made this the same? :D I tried to bypass the switch but no luck, my guess is that on the back the negative/ground for the ON position without the door opened is bad. I think there is a positive 12v wire and two ground wires, when you open the door one wire switches ti ground and the second should to the same, why isn't it working???
 

·
Registered
Joined
·
2,271 Posts
Visor light isn't door related. It just has a switch but ignition must be on.
I'll check the manual sometime maybe take a picture of the relevant twaddle.
 

·
Registered
Joined
·
2,028 Posts
Not really that stupid. I got fed up with passengers turning on interior lights in my old Espace, that I failed to spot until the battery was flat a day or two later.
 

·
Registered
Joined
·
58 Posts
Discussion Starter #7
I get you halftone. Checked the passenger light, it works with ignition on. But still no luck with rear interior lights...sometimes I need it for my kid to see what is happening so I need to fix it
 
1 - 7 of 7 Posts
Top