Alfa Romeo Forum banner
1 - 20 of 26 Posts

·
Registered
Joined
·
208 Posts
Discussion Starter · #1 ·
Hi all, I've just bought a 2009 159 1.8TBI with 100k on the clock. This morning on the drive to work it twice briefly flashed up with 'insufficient oil pressure, stop engine' or something along those lines. The oil level was ok, but as I was worried I took it to a local garage who do Alfas, they said it's likely a faulty sensor, or just that it needs the oil changed/service reset. They said not to worry and I've booked it in with them so they can have a look. I'm just worried that it could be something more sinister?
I think they said the sump would need dropped to access the sensor, so 2-3 hrs labour plus the sensor which he was guessing at £200. The oil is due a change as it's over by a few days, but still under by a few miles.
The garage did reassure me, but I thought I'd ask on here anyway.
 

·
Registered
Joined
·
3,024 Posts
Carry on with your plan but as they've got the sump off, ask them to check one of the big end bearings for signs of wear. (10 min job)
 

·
Registered
Joined
·
7,446 Posts
Did you almost stall the engine? My last 147 would come up with that message if the revs dropped very low, typically when I almost stalled the engine but managed to catch it.
 

·
Registered
Joined
·
1,270 Posts
oil is due according to service manual mileage intervals? note that it should be at least halfened (say 7-10kmiles depends if you drive city or motorways), if you want to keep engine clean and turbo healthy. use good oil (not selenia star pe), could be selenia sport power(giulietta tbi dedicated since a few years, also on selenia website recommended for 159tbi) or other good like e. g. motul xclean 5w40 c3. i would do engine oil flush before the change to clean all a bit, especially if previously manual recommended selenia star pe was used. also, it is for sure time to change tiny screw-filter before turbo (cost like gbp10+needs 2 new copper washer-gaskets) .
let us know what your serviceman finds as the reason for low pressure - i never heard such case for tbi engine,hopefully it is only sensor. i think only 2.0jtdm (so also opel insignia 2.0cdti, the same engine) may have problem (design issue) with potential low oil pressure due to split of the oil pump from sucking element (existence of gasket which over time looses seal, and needs replacement).
 

·
Registered
Joined
·
33 Posts
Did you almost stall the engine? My last 147 would come up with that message if the revs dropped very low, typically when I almost stalled the engine but managed to catch it.
My 159 1.8Tbi also has the same message what I almost stall the engine. It happened more when I first got the car while I was getting used to the clutch etc...
 

·
Registered
Joined
·
208 Posts
Discussion Starter · #7 ·
I'm thinking maybe that's all it was, it hasn't done it again since. It did happen on the 1st day of driving it and the clutch bite point is very low on the peddle compared to our 159 diesel. I do remember being surprised it didn't stall. I'll get them to check it anyway and let you know if they find anything.
 

·
Registered
Joined
·
208 Posts
Discussion Starter · #8 ·
"tiny screw-filter before turbo" is that on the turbo oil feed pipe? Would never have thought of checking there for a filter. The service reminder is set for 365 days or 21k, the previous owner did a fair amount of motorway miles.
Any idea what the cambelt interval is on the TBI, can what it says in the handbook be trusted or is it best to do it sooner? Have had a quick look online and one Alfa place says 63k miles or 4 years which is the same as the handbook.
 

·
Registered
Joined
·
360 Posts
Welcome to TBi ownership, not seen another in Hampshire in the 2 years I've had mine.

Wouldn't worry about the warning as long as it came up just before a stall or near stall, I've done it a few times especially when I first got the car. I personally found it not the easiest throttle to master, maybe it's my car or just me :biglaugh:

Which garage are you looking at taking it to by the way?
 

·
Registered
Joined
·
208 Posts
Discussion Starter · #10 ·
Welcome to TBi ownership, not seen another in Hampshire in the 2 years I've had mine.

Wouldn't worry about the warning as long as it came up just before a stall or near stall, I've done it a few times especially when I first got the car. I personally found it not the easiest throttle to master, maybe it's my car or just me :biglaugh:

Which garage are you looking at taking it to by the way?
Thanks, when I saw this tbi for sale I snapped it up, I'd been looking/browsing for another 159 or Brera for years, but never actually bought one. Couldn't decide on 2.4JTD or 2.2 decided 3.2 was probably too extravagant. It's booked in at Alltecnique in Salisbury because I work round the corner from them, so don't need to take time off work to get it there. I've not had any work done by them before, just replacement key programming, but they seem to know what they're on about and the vehicles (not Alfas) from work all go there.
 

·
Registered
Joined
·
1,270 Posts
"tiny screw-filter before turbo" is that on the turbo oil feed pipe? Would never have thought of checking there for a filter. The service reminder is set for 365 days or 21k, the previous owner did a fair amount of motorway miles.
Any idea what the cambelt interval is on the TBI, can what it says in the handbook be trusted or is it best to do it sooner? Have had a quick look online and one Alfa place says 63k miles or 4 years which is the same as the handbook.
yes, on oil feed pipe to the turbo. There are 2 scenarios likly possible.
1.The plastic filtering grid within the screw-filter (not sure if I used good words, but hope enough descriptive), already cracked because of aging of plastic, because of stress/pressure caused by cold/dense oil flow after start of cold engin, because of dirt which was collected on fltering grid. In that case you have no problem with flow, but sometimes bits and pieces of that plastic filtering grid tear off, and go thrugh turbo to engine, which probably is not the best for engine in general (but never heard of any engine harm from people who confirmed the filter grid was in pieces)
2.Filtering grid keeps solid, but the flow through grid is reduced due to dirt. Turbo may not get proper oil flow.

I heard complaints of people who used Selenia Star PE (e.g. my friend in Giulietta 1.4 MA 2010, in that time it was recommended oil) that the oil feed pipe was nearly stuck with dirt after 40kmiles, and so he replaced it the pipe together with screw-filter. Thats why I was talking about good oil earlier, specially as only known issue of TBI engine is turbo failure (not that common, but happens).

In terms f cambelt intervals, that seems more or less OK to me. I replaced mine at 4.5 years, and the car was only 30kmiles.
 

·
Vendor
Joined
·
47,257 Posts
Any of you with a 1750TBI and planning a long ownership - I would seriously recommend changing your engine oil way, way sooner than they suggest in the service book. I'd do mine every 7 to 8 thousand miles if I owned one.
 

·
Registered
Joined
·
360 Posts
Any of you with a 1750TBI and planning a long ownership - I would seriously recommend changing your engine oil way, way sooner than they suggest in the service book. I'd do mine every 7 to 8 thousand miles if I owned one.
I'm hoping I caught mine in time (2nd owner) and have been changing the oil at the sort of mileage you suggest, must get it tested next time to see how much fuel is in the oil.

Have you seen many turbo TBi failures recently?
 

·
Registered
Joined
·
1,270 Posts
when i was looking for tbi last year (across germany, poland, netherlands, austria, italy, as was hard to find spec/coulour/mileage just in poland) i seen number of adverts with full service history and mentioned turbo change at 60-80kkm (i was looking for cars up to 100kkm).
one guy (who has alfa specializing workshop and is very active on polish alfa technical forum) said that luckily this turbo can be repaired for around of gbp200 + replace costs.
 

·
Vendor
Joined
·
47,257 Posts
I'm hoping I caught mine in time (2nd owner) and have been changing the oil at the sort of mileage you suggest, must get it tested next time to see how much fuel is in the oil.

Have you seen many turbo TBi failures recently?
Done 4 this year..
 

·
Registered
Joined
·
4,194 Posts
oil is due according to service manual mileage intervals? note that it should be at least halfened (say 7-10kmiles depends if you drive city or motorways), if you want to keep engine clean and turbo healthy. use good oil (not selenia star pe), could be selenia sport power(giulietta tbi dedicated since a few years, also on selenia website recommended for 159tbi) or other good like e. g. motul xclean 5w40 c3. i would do engine oil flush before the change to clean all a bit, especially if previously manual recommended selenia star pe was used. also, it is for sure time to change tiny screw-filter before turbo (cost like gbp10+needs 2 new copper washer-gaskets) .
let us know what your serviceman finds as the reason for low pressure - i never heard such case for tbi engine,hopefully it is only sensor. i think only 2.0jtdm (so also opel insignia 2.0cdti, the same engine) may have problem (design issue) with potential low oil pressure due to split of the oil pump from sucking element (existence of gasket which over time looses seal, and needs replacement).
Worth changing that seal also, assuming it is similarly designed?
 

·
Vendor
Joined
·
47,257 Posts
Ouch, so it is a case of when mine goes rather than if....
Well there must be a few hundred on the roads in 159s & Breras, even more so in the Giulietta with this engine. However there are lots of things that conspire against the turbo on the 1750 lasting a long time:

1) Direct injection - these engines are known for petrol dilution of the engine oil. We have seen upwards of 3% dilution with fuel when sending the oils off for analysis. Petrol is not a good lubricant...

2) Heat - there is a dirty great big cat strapped directly to the turbo outlet, all sandwiched in front of the engine, behind the radiator. Cooling is poor, it all gets really hot in regular use, even hotter when driven hard, probably because of point 3

3) 1.75 litres is a small engine for a big car. Consequently the turbo is working hard a lot of the time. More so than it would do on a 2.4 JTDM for example

4) Oil supply is poorly designed. A narrow pipe comes from the engine and passes near to the exhaust manifold, turbo exhaust housing and catalyst, this gets really hot and the oil inside this pipe can bake, especially when the engine is turned off and flow stops. Carbon in the oil burns onto the inside of this feed pipe, further restricting flow. Once oil flow to a turbo is restricted it is only a matter of time.

Best thing you can do is change the oil regularly. Let the car warm up nicely before driving hard and make sure the last few miles of a journey are steady to allow things to cool down. A little bit of idling when you arrive at the destination like on an old school turbo engine wouldn't hurt either.
 

·
Registered
Joined
·
1,270 Posts
Worth changing that seal also, assuming it is similarly designed?
as far as i heard and read, only 2.0jtdm has splited oil pump from oil sucking element(which is part of oil sump and presses to oil pump through gasket, and after some time it works worse and worse).
tbi needs oil changes and good flow of oil to turbo. from what i read on some giulietta forum re these screw-filters the reasonable rule is to have screw-filter replaced say every 3 oil changes (or filtering grid removed, some say that filter causes more potential issues than benefits), and pipe inspected if it is clean.

found screenshot wth tbi screwg-filter and copper washer-gaskets part numbers
https://goo.gl/photos/rvJWxNeRJPBXZh7U8
 

·
Registered
Joined
·
3,024 Posts
Well there must be a few hundred on the roads in 159s & Breras, even more so in the Giulietta with this engine. However there are lots of things that conspire against the turbo on the 1750 lasting a long time:

1) Direct injection - these engines are known for petrol dilution of the engine oil. We have seen upwards of 3% dilution with fuel when sending the oils off for analysis. Petrol is not a good lubricant...

2) Heat - there is a dirty great big cat strapped directly to the turbo outlet, all sandwiched in front of the engine, behind the radiator. Cooling is poor, it all gets really hot in regular use, even hotter when driven hard, probably because of point 3

3) 1.75 litres is a small engine for a big car. Consequently the turbo is working hard a lot of the time. More so than it would do on a 2.4 JTDM for example

4) Oil supply is poorly designed. A narrow pipe comes from the engine and passes near to the exhaust manifold, turbo exhaust housing and catalyst, this gets really hot and the oil inside this pipe can bake, especially when the engine is turned off and flow stops. Carbon in the oil burns onto the inside of this feed pipe, further restricting flow. Once oil flow to a turbo is restricted it is only a matter of time.

Best thing you can do is change the oil regularly. Let the car warm up nicely before driving hard and make sure the last few miles of a journey are steady to allow things to cool down. A little bit of idling when you arrive at the destination like on an old school turbo engine wouldn't hurt either.
You're a fan of the 1750 unit then, huh?:rofl::rofl:
 
1 - 20 of 26 Posts
Top