Alfa Romeo Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
6,502 Posts
Discussion Starter #1
Chaps

Latest problem: Started the car no problem this morning, but it was making a terrible racket from the heater/cooler fans.Jiggled with controls,turned car off & on and problem went away.
Drove car,stopped at junction,stalled.Started ok and went for a 1 hour walk.
On coming home,slowed at lights,stalled again.Yet again managed to get her started.However not so lucky at next set of lights,stalled and car refused to start !!
Turned over ok but nothing else.I did notice that the injection warning light stayed on at MAR.
Came back 1/2 hour later and she started first time........!!!
I've taken the battery out for 45 mins and now everything seems ok.No injection light on.

What's it all about and should i be worried ?:confused:
 

·
Registered
Joined
·
9,912 Posts
error probably ecu reset it self cos it was intermittant
taking battery off must have erased error in ecu ,you might be luckky and problem dont come back
 

·
Registered
Joined
·
6,502 Posts
Discussion Starter #3 (Edited)
Right chaps,same thing happened again.5 minute drive,temp never got above 59 degrees then once hit 60 it cut out.I had a inkling it was temp related....waited 10 minutes, temp came down ,car started and got her home.
Just out of curiousity kept her running in drive and 1 minute later she cut out.
When she's below 60 degrees she runs perfectly.

What's causing this ?

Sorry I've just read other threads....are we in crank sensor territory.....we had a new one put in 4 years ago....are they known for failing ?

And just to confuse matters I'm just after getting the keys reprogrammmed after immobiliser code light stayed on. !!
 

·
Registered
Joined
·
6,502 Posts
Discussion Starter #5 (Edited)
Just ran the car in driveway for 25 minutes...ran fine,went up to nearly 95 degrees and fan came on as normal.
Could it be something as simple as dirty fuel,ran a bit low this week but then filled her to brim 2 days ago ?
 

·
Registered
Joined
·
6,502 Posts
Discussion Starter #7
Dirty fuel was a red herring !
Forgot to say that there is a very noticeable rattle between the steering wheel and the engine....could this have anything to do with it ? Can the crankshaft sensor come loose ?
 

·
Registered
Joined
·
6,502 Posts
Discussion Starter #9
Yeh,I'm getting that done tomorrow.
Just out of interest, if it's either crankshaft or cam sensor,is there much difference in supplying & fitting ?
 
1 - 9 of 9 Posts
Top