Alfa Romeo Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
New GTV owner (year 2000), I have a small prob and wondered if any of you you have come across it before ?

I locked the car and went to a shop when got back and unlocked ,all the indicators were permanently on as well as both indicator lights on the dash.
I cant turn them off and the indicators will not direction flash. I suspect it may have something to do with the alarm ? any ideas ? frustratingly
Ben
 

·
Registered
Joined
·
5,820 Posts
Try cycling the hazard warning button several times. If that doesn't work and you have the factory alarm try disabling it, you will find the module under a small plastic cover located on the large plastic cover under the bonnet, driver's side. If it is there you need the odd shaped key for that.
 

·
Registered
Joined
·
2,016 Posts
Indicators relay is in a line of three relays to the left of the fuse box, slightly right of the steering column.

Sent from my SM-G950F using Tapatalk
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
New GTV owner (year 2000), I have a small prob and wondered if any of you you have come across it before ?

I locked the car and went to a shop when got back and unlocked ,all the indicators were permanently on as well as both indicator lights on the dash.
I cant turn them off and the indicators will not direction flash. I suspect it may have something to do with the alarm ? any ideas ? frustratingly
Ben
thanks very much !!
 

·
Registered
Joined
·
2,362 Posts
It could be the alarm. If you have a separate key and alarm fob then you have a Meta M99 alarm. Undo the passenger side carpet bit to get at the ECU which is under the stereo. Unplug the ECU. You’ll need to unlock the car with your keys but if it sorts you indicator issue, send off you ECU to Abacus Alarms and they’ll sort it for you.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #7
Thanks for the tip , somebody has already disabled the alarm by cutting the wires at the back of it but trying to remove the ECU might be a way to go . I think it could be hazard and indicator relay and may try this first?...
 

·
Registered
Joined
·
2,016 Posts
Thanks for the tip , somebody has already disabled the alarm by cutting the wires at the back of it but trying to remove the ECU might be a way to go . I think it could be hazard and indicator relay and may try this first?...
Its easy to try that first.

Sent from my SM-G950F using Tapatalk
 
1 - 8 of 8 Posts
Top