Alfa Romeo Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
801 Posts
Discussion Starter #1
Hi all.
I have had my 145 QV for a week and a bit now. Cleaned it twice, but with all the snow and being a black (looks damn fine when it's clean) car, it just has to look at the roads and it's filthy again. Bring on the summer......
After a year of driving a 306XSI and before that a 1.9 205GTI I am pleased to say that this car rocks!! Still like my Pugs though.
Dodger.
 

·
Registered
Joined
·
6,451 Posts
Welcome aboad Dodger. :)
 

·
Registered
Joined
·
12,386 Posts
Yes, Welcome to AO Dodger :)
 

·
Registered
Joined
·
31,304 Posts
Hi Dodger, welcome to AOer.com :)

We'll be wating for that piccies. ;)
 

·
Registered
Joined
·
801 Posts
Discussion Starter #5
I'll get some photos up when I can get some smaller ones, maybe this weekend. I have some good ones from when it was covered in snow, but they are too big for this site.
Touch wood, but so far the car goes really well. A couple of things I need to fix in true Alfa fashion. Headlamp reflector has detached itself, side skirt has broken one clip and the exhaust has started to blow (don't know how I missed it when we were looking......).
On the good side, the wipers and windows work!!
Dodger.
 

·
Registered
Joined
·
45,472 Posts
Welcome to the forum Dodger :cool:

Post your piccies in the Just Images section. Here are the relative instructions to do so (sticky from there), including how to resize any existing pictures you might have to share ;)

http://www.alfaowner.com/Forum/showthread.php?t=31365
 

·
Registered
Joined
·
3,221 Posts
Welcome to AO. :)
Enjoy the QV :cool:

:D Nice pic!
 

·
Registered
Joined
·
31,304 Posts
Lovely! :cool:
 
1 - 9 of 9 Posts
Top