Alfa Romeo Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
74 Posts
Discussion Starter · #1 ·
I'm starting to freeze driving my Alfa. I only get very slightly warmed up air inside the car, which is not enough on chilly mornings and threatens to be a major problem in the winter.
The problem seems to be the temperature control dial. It turns very easily and if turned only half way it snaps back into zero position by itself.
Has anyone had any experience with such kind of a problem? Could it be some kind of faulty cable connected to the dial (if there is a cable). I had the entire heater replaced when I bought the car (because the fan worked only in 4th position). Can there be a relation?
I also checked the coolant level, which is ok. My car does not have air con.
Thanks in advance for any advice.
 
G

·
There is probably a cable or lever trapped or not sitting properly behind the dash from when the work was done. Had a similair problem on another car.

Marlon
 
G

·
If the engine heats up correctly, then it's most likely to be the heater controls need setting up. There is a fair bit of adjustment on the flap & cables (apparently). If not then the thermostat could be gone or on its way.

cheers,
alex
 

·
Registered
Joined
·
74 Posts
Discussion Starter · #4 ·
Anyone attempted dismantling the dash? Does the central piece come off separately or the whole thing has to be taken apart?
 
G

·
Take the ashtray out, unscrew the warning light panel and pull out, and then the heater controls should just pull out. I am not 100% sure if this will work with the heater dials as mine as the push button controls.
Ian.
 

·
Banned
Joined
·
477 Posts
I think i've got a similar thing in the Punto. If the fan is on speeds 3 and especially 4, the temperature dial feels as though it is possessed and wants to return to the cold position. Not figured anything out though. The fan is very noisy on top speed. Sorry to be of no help whatsoever :confused:
 
G

·
take out the glove box and the side trim off the heater(left side)you will see that the pivot just above the heater tap is broken.....(i think)
 
1 - 7 of 7 Posts
Top