Alfa Romeo Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
56 Posts
Discussion Starter #1
hi everyone i went to the shops in my 156 sportswagon 1.6ts and when i came out of the shop and started it, the car wouldnt stay running only if you press the throttle and keep the revs up that way.
when i got home the car idled on its own but lumpy, it then dropped then came back up and fluxtuating,
as soon as you dip the clutch when approching to a junction it dies

it would be much appreciated if someone could help
thank you very much for taking time too read this

THANKS VERY MUCH
:thumbs:
 

·
Registered
Joined
·
119 Posts
MAF (Mass airflow) Sensor gone. Try unplugging it and start the car ... it should idle smoothly (don't drive the car with the MAF unplugged!) .
 

·
Registered
Joined
·
56 Posts
Discussion Starter #3
idle

hi there thanks very much for the reply, the car idles but when you rev, the revs drop way below the 1000rpm mark doesnt cut out but it borks when it drops but then the idle comes back up
its stopped cutting out but its still drops to far then comes back up as if it was going to stall
thanks very much for your help i really appreciate all your help
thanks dovo:thumbs:
 

·
Registered
Joined
·
11,604 Posts
Check the intake hosing for tightness & splits / cracks - my understanding is that when the MAF is unplugged the idle will be rough anyway...
 

·
Registered
Joined
·
56 Posts
Discussion Starter #5
idle is rough

hi thanks very much matey just had a look and it looks like there is a hole in my airbox of a stone going to replace that then ill let you's know thanks guys
:thumbs:
 

·
Registered
Joined
·
11,604 Posts
I would expect a hole / split after the MAF to cause your symptoms although a hole in the airbox ain't good
 

·
Registered
Joined
·
56 Posts
Discussion Starter #7
idle is rough HELP

hi there the car still has the same prob but its worse when its warm the idle drops all the time sometimes even stalling its a manual throttle body with a stepper motor on the otherside ive cleaned the air flow meter, and its still doing it any body got any ideas dont have alot of money to replace thing just to see if its that lol
thanks everyone i would appreciate it if you could help
 
1 - 7 of 7 Posts
Top