Alfa Romeo Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
59 Posts
Discussion Starter #1
Hello All !

This w-e, I changed the sparking plugs on my V6... not easy for the rear bank... Since I made it, I get an idle at at least 1200 rpm, even when hot...
Has anybody an idea on the reason ?

Thanxs for help....

Val
 
J

·
Guest
Joined
·
0 Posts
how long ago did you change the plugs? Could it be that the ecu is remapping itself? Dont listen to me, see speedys reply below. That is what i was meaning to say.
 

·
Registered
Joined
·
4,651 Posts
Val you may have disturbed the Idle Actuator Unit or poss pulled a pipe partially off :rolleyes: it check the pipes are a tight fit and maybe whip the idle thingy off and give it a clean :D

Other than that check and make sure yoiu havent got anything fouling the throttle cable/linkage :D
 
F

·
Guest
Joined
·
0 Posts
Hmmm what should a V6 tick over at ???, the Beast has always had a very random tickover, anywhere between 800 and 1200, and hunting up and down between the 2 all the time... since putting new plugs in not long ago i get a pretty steady 1200 rpm tickover and much less cutting out, the car is greatly improved to be honest.
When cold its still an absolute ***** for the first mile, but when Jamie porter did the remap, the only way they could get it to tickover was to make it run very rich at idle... not flipping rich enough for me to be honest... and they reckon it had very high lift cams in, which wont help either... carnt wait till they wear out..££££
 
W

·
Guest
Joined
·
0 Posts
I'm with Speedy, the idle actuator is on the rear bank near the far left spark plug...had to remove mine to get at the plug. Perhaps you've disturbed something...must have if it was ok before the new plugs :(

wrinx
 

·
Registered
Joined
·
4,651 Posts
wrinx:
I'm with Speedy, the idle actuator is on the rear bank near the far left spark plug...had to remove mine to get at the plug.

wrinx
Why????? i got all my plugs out without removing anything :confused: except the leads of course :rolleyes:
 

·
Registered
Joined
·
59 Posts
Discussion Starter #11
wrinx:
I'm with Speedy, the idle actuator is on the rear bank near the far left spark plug...
Hi guys,

Thanx for your help... I'm gonna have a look tomorrow....
Wrinx, left spark when you sit or when you're front of the engine ?

Val
 

·
Registered
Joined
·
4,651 Posts
When your looking from the front of the car its the furthest right on the rear bank ..................and when your sat in the car its the furthest left :rolleyes: :p


The Idle Actuator is approx 4-5 inches long and 2 inches round silver in colour and with a wiring plug on one end and 1 or 2 breather pipes on it

Easiest thing to do is to take it off and clean it out with Carb Cleaner and check the little round air flap thingy inside is free :D Sorry cant be more clear on me description but once its off you`ll probably understand :D :rolleyes:
 
1 - 14 of 14 Posts
Top