Alfa Romeo Forum banner

1 - 20 of 899 Posts

·
Registered
Joined
·
176 Posts
I don't believe this!

I've been waiting 7 weeks for Alfa dealer to get me the ICS code.

I had to take the ICS unit out of the dash, took photos of all the codes/labels etc. on it and emailed them off to them, and was told they have to contact the factory in Germany and it will be 8-10 weeks.

Saw this post, found the pics and tried the number on the label and it works!
1) How come the Alfa dealer couldn't tell me this?
2) How is this a security code if it is stuck on the side of the unit?

Rant over, thanks for the very useful post...

Colin W
 

·
Registered
Joined
·
19 Posts
Discussion Starter #7
boyse7en said:
I don't believe this!

I've been waiting 7 weeks for Alfa dealer to get me the ICS code.

I had to take the ICS unit out of the dash, took photos of all the codes/labels etc. on it and emailed them off to them, and was told they have to contact the factory in Germany and it will be 8-10 weeks.

Saw this post, found the pics and tried the number on the label and it works!
1) How come the Alfa dealer couldn't tell me this?
2) How is this a security code if it is stuck on the side of the unit?

Rant over, thanks for the very useful post...

Colin W
:mad: What about car security think Alfa Romeo......
:) Yes - security code is stuck on the side of the unit....
 

·
Registered
Joined
·
23 Posts
thanks for that :)
I'm still waiting for Siemens to supply the ICS code I mean it's only been 12 weeks for **** sake :rant:
 

·
Registered
Joined
·
46 Posts
spot said:
thanks for that :)
I'm still waiting for Siemens to supply the ICS code I mean it's only been 12 weeks for **** sake :rant:
Did you request the code at Siemens itself ??
Because they send me to the local dealer
Curious, just asked my local ALFA Dealer thursday the satnav code for the two satnavs i purchasesd ,we will see how long that takes to come thru.
 

·
Registered
Joined
·
11 Posts
I have retro fitted a G2 nav system to my 166. I did all the cabling
etc. felt pretty please with myself. Bought a nav box from a breakers
and applied to Alfa for the code (Siemens were not interested) It took
11 weeks for them to get me the code.

Everything loaded up fine but reading the disk started to cause problems now it seems that I have a faulty CD deck.

Can anybody help?
 

·
Registered
Joined
·
23 Posts
Mart said:
Did you request the code at Siemens itself ??
Because they send me to the local dealer
Curious, just asked my local ALFA Dealer thursday the satnav code for the two satnavs i purchasesd ,we will see how long that takes to come thru.
no I went thru a dealer
 

·
Registered
Joined
·
3 Posts
Hello!

I have similar problem - no ICS. I could get trough local dealer, but he wants 150€ foe CODE!!!!

I took my ICS out and sdly i Couldnt find the ICS code. On the picture on attachment are two sticker and on the bottom you can find ICS - but my bottom code is missing!!! Only the top one...

I read that there are some calculators which can get ICS code from serial number - anyone?

Please help me, as you see my dealer (and everywhere in Slovenia is the same) wants too much money!!!

Thank you and best regards,
Gargy
 

·
Registered
Joined
·
19 Posts
Discussion Starter #14
Gargy said:
Hello!

I have similar problem - no ICS. I could get trough local dealer, but he wants 150€ foe CODE!!!!

I took my ICS out and sdly i Couldnt find the ICS code. On the picture on attachment are two sticker and on the bottom you can find ICS - but my bottom code is missing!!! Only the top one...

I read that there are some calculators which can get ICS code from serial number - anyone?

Please help me, as you see my dealer (and everywhere in Slovenia is the same) wants too much money!!!

Thank you and best regards,
Gargy
:rolleyes: I don't know does it work for you, but you can also try to press buttons on your ICS (CLIMA+DARK). It's possible that you can read your code from LCD screen.
Link: http://www.alfaowner.com/Forum/showthread.php?t=42808&highlight=ics
PICTURE: http://www.alfaowner.com/Forum/attachment.php?attachmentid=14367
 

·
Registered
Joined
·
3 Posts
Hey, thanks ALFA_166,

but it doesn't work. I have on display "Please input code for ICS" for a while now. I wont pay 150€ because it's a rip-off! Sadly, former owner has lost his ICS code :mad:

Any other idea?

Best regards,
Gargy
 

·
Registered
Joined
·
6,298 Posts
150€ is crazy....even the £15 the dealer charged me here in the UK was a rip off as all the do is tap a few numbers into the main fiat computer and out pops all the security codes.
 

·
Registered
Joined
·
3 Posts
Yes, I know...

Service guy told me, that they have to pull ICS out, get every possible code, then send this codes together with my data (ownership, licence number etc) to Alfa Romeo Italy and then wait minimum of 10 days to get the code
:rant:

Regards,
Gargy
 

·
Registered
Joined
·
3 Posts
I recently imported a 166 from Japan. It was dead on arrival and it turned out to be a fried Air Bag ECU. $2,200 later I collected the car and the ICS didn't work. After a lot of heartache I was told the dealer would need to pull out the ICS and send the numbers to Italy in order to get the ICS working. But... they were fully booked and I had to wait 2 weeks. While I was waiting the car sat outside and the battery went flat. Scared to jumpstart (no more fried ECU's for me) I purchased a new battery.

To cut a long story short, after disconnecting the battery and fitting a new one I jumped in the car to drive it to the dealer. I was delighted to find the ICS had activated itself WITHOUT A CODE HAVING TO BE ENTERED!!! So for the people out there stressed about not having an ICS code, just disconnect your battery for 5 minutes.

My problem is not completely over, the ICS is in Japanese so I need to find out how to code it for English. If anyone knows, please advise.
 

·
Registered
Joined
·
11 Posts
Emoto said:
I recently imported a 166 from Japan. It was dead on arrival and it turned out to be a fried Air Bag ECU. $2,200 later I collected the car and the ICS didn't work. After a lot of heartache I was told the dealer would need to pull out the ICS and send the numbers to Italy in order to get the ICS working. But... they were fully booked and I had to wait 2 weeks. While I was waiting the car sat outside and the battery went flat. Scared to jumpstart (no more fried ECU's for me) I purchased a new battery.

To cut a long story short, after disconnecting the battery and fitting a new one I jumped in the car to drive it to the dealer. I was delighted to find the ICS had activated itself WITHOUT A CODE HAVING TO BE ENTERED!!! So for the people out there stressed about not having an ICS code, just disconnect your battery for 5 minutes.

My problem is not completely over, the ICS is in Japanese so I need to find out how to code it for English. If anyone knows, please advise.[/QUOTE
Push button 'TRIP' go settings, language and select.
Hope this helps
 
1 - 20 of 899 Posts
Top