Alfa Romeo Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Hi all !!!

After bad battery connection i`ve lost bluetooth on my 159. Steering wheel button doesn`t react on it. Previously, the button showed the language on the display and blue&me worked properly.
Now i tried several methods, battery disconnect , proxy alignment with alfa OBD elm327. But no result. Can someone tell me is it possible to solve the problem?

Usb doesn`t react on flash for updating or instaling Blue&me soft
 

·
Registered
Joined
·
3,585 Posts
Go into car menu and try to reset all phone settings, that solved mine - you'll have to set tour phone connection to the car up from scratch though
 

·
Registered
Joined
·
1,259 Posts
Is your proxi config all right?
B&M is known to be prone for failing - if above did not help, I guess you may need to start looking for new B&M unit. not fully sure about compatibilities -my experience is with retrofitting B&M to my former 2010 TBi, where first I retrofitted standard B&M from post facelifting car, and later fitted B&M nav (added 3rd party antena compatible with the connector, and plugged in USB stick with maps and get all working all right). With nav version I had some difficulties though, some proxi settings needed change (display type was the issue, needed to change it but on top of my head do not remember for what; but that was regarding navigation part menu not working, all the rest was OK).
in Poland 2nd hand B&Ms are sold for order of EUR30-40 in average, but sometimes it is not possible to find any compatible B&M on auction/advert.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #5 ·
Is your proxi config all right?
B&M is known to be prone for failing - if above did not help, I guess you may need to start looking for new B&M unit. not fully sure about compatibilities -my experience is with retrofitting B&M to my former 2010 TBi, where first I retrofitted standard B&M from post facelifting car, and later fitted B&M nav (added 3rd party antena compatible with the connector, and plugged in USB stick with maps and get all working all right). With nav version I had some difficulties though, some proxi settings needed change (display type was the issue, needed to change it but on top of my head do not remember for what; but that was regarding navigation part menu not working, all the rest was OK).
in Poland 2nd hand B&Ms are sold for order of EUR30-40 in average, but sometimes it is not possible to find any compatible B&M on auction/advert.
The fact is that when i`m starting proxy alignment it stops running and then i have to restart obd connection. CAN shows some errors
 

·
Registered
Joined
·
3,585 Posts
I'm afraid I can't remember, and I binned off my blue&me in favour of a new head unit - do you have the user manual?
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #8 ·
I'm afraid I can't remember, and I binned off my blue&me in favour of a new head unit - do you have the user manual?
I'll describe all of my steps that i did on recomendations:

1. I disabled battery for 20 minutes
2. I checked usb conection
3. I checked all fuses and relays related to device
4. I did proxy allignment

1. Battery disable did't help
2. The blue&me device didn't react on usb drive

Alfa OBD2 couldn't connect with blue&me device either radio

Steering wheel knobs doesn't react
For calls

The one thing that i have to do is

1. To check device mass connection
2. To check the blue&me device on work

Now i'm waiting for set replacement tools to do this work. After i'll post the results
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #10 ·
have you tried connecting via obd to blue&me module? note it happens that these modules completely or partially die

Yes i tried to connect obd directly to blue&me module but unsuccessfully. I tried to connect it with radio but also unsuccessfully. Radio works normaly unlike blue&me module.
 

·
Registered
Joined
·
1,259 Posts
if you have both supplies for b&m present at bm connector, gnd and CAN (check continuity e.g. with radio CAN), then you shouls see bm using MES or other OBD tool. i sbiff your BM just diedybricked what happens sometimes (i heard of say 10 cases over years on polish AR forum)
 
1 - 12 of 12 Posts
Top