Alfa Romeo Forum banner
1 - 4 of 4 Posts
G

·
Discussion Starter · #1 ·
Hi! At first Marry X-mas! - but not so marry. Yesterday my ALFA (155 2.0 TS 16v Super) didn't want start! I need a HELP!!! At first - it was cold (-25° C), and BATTERY died, it turned the engin four times - and died, and then began to flash the warning light "ALFA CODE". I changed the battery, but it didn't HELP me, warning light flashing, and engin didn't want to start!!!
Six month ago i have a problem like this. I taked off the battery from my car, and then put it in a place. After this combination when i started to work the engin began to flash the warning light "ALFA CODE". In ALFA service their cheked electronical system, and maked decision the immoboliser antenna has broken. Their changed it, and it was OK'.
And now the same problem? - BUT I CAN BELIVE in 6 month i have to change a second immobilizer's antenna? But i know in both cases it started from BATTERY.
Could you HELP me???!!! Please!
Sorry for my English!!! I hope you understand me!
 

·
Registered
Joined
·
550 Posts
CAROLLL, CHECK THE PUMP FUEL RELAY SITES AT THE FRONT OF THE ENGINE, BESIDES THE BATTERY.
GOOD LUCK
JORGE
 
G

·
Discussion Starter · #3 ·
Hi Carolll
If you've had a battery problem you may need to recode the ALFA CODE.

1. Insert the master key(red) and turn it to MARCIA then back to off as soon as the CODE light goes out.
2. Within 10 seconds insert a normal key and turn it to MARCIA then back to off as soon as the CODE light goes out.
3. Repeat step 2 with all other keys.
4. Finally insert the master key again and turn it to MARCIA then back to off as soon as the CODE light goes out.

This worked for me after I had my battery disconnected for 4 hours and all I was getting was a flashing ALFA CODE light and no starting
 

·
Registered
Joined
·
89 Posts
I need to disconect my battery, but i dont know how to insert my code key. I have a 147 1.6ts with two identical black keys. can i insert the code myself?
 
1 - 4 of 4 Posts
Top