Alfa Romeo Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
55 Posts
Discussion Starter #1
Ok so in relation to my knocking sound thread, I've now got the replacement pulley from Auto Lusso, doesn't look any different from mine tbh, if anything mine 'appears' in better condition, i.e. less rust etc. However, if it's the rubber dampener that's the problem, I wouldn't see the difference I suppose. Anyway, I was hoping the belt wouldn't be under too much tension, as I couldn't see a way to un-tension it, so I went ahead and removed my old pulley, which apart from arm ache because of so many small bolts to remove, was quite easy. Now I'm stuck though, how the hell, do you un-tension this belt, so that I can get the new pulley on? lol
 

·
Registered
Joined
·
635 Posts
You need to undo the tensioner. Its above and to the right of the crank pulley. Undo the nut and it spins down to release the tension. There is a method to correctly re-tension. It involves a locking pin in the auto tensioner. Do a search. There has been alot written about it.

Good luck. ;)
 

·
Registered
Joined
·
55 Posts
Discussion Starter #3
I ended up bodging it on, big flathead screwdriver through the hole in the pulley, using the bottom of the crank shaft nut to lever it and a hammer to bang it on, dirty I know, but it worked and the tensioners are all still set the same. There's a risk I may have stretched the belt a bit granted, but it's still tight and was brand new a few months back. Either way, it didn't fix my knock :( So back to the other thread, lol.
 
1 - 3 of 3 Posts
Top