Alfa Romeo Forum banner

41 - 60 of 163 Posts

·
Premium Member
Joined
·
7,097 Posts
Discussion Starter #41
Ah perfect! So, I will proceed. Do you suggest to upgrade firmware first, then the map?
doesn't really make a difference, updating the firmware will not erase the map with your version....
Firmware update takes 10~15 minutes, map update 30~40 minutes..... I think I'd start with firmware.
 

·
Registered
Joined
·
10 Posts
Ah perfect! So, I will proceed. Do you suggest to upgrade firmware first, then the map?
doesn't really make a difference, updating the firmware will not erase the map with your version....
Firmware update takes 10~15 minutes, map update 30~40 minutes..... I think I'd start with firmware.
Sorry but...i was reading the v85 technical specs and I'm thinking about this paragraph (see attachment). If I start the upgrade from 051,then i go to 056 and then I decide to put on 085, could something mess up? Because I don't understand if it is necessary to reprogram the other modules (AMP, BSM, IPC, PAM, LBSS, RBSS, BCM). They would remain untouched. The car is over April '18 but with oldest firmware, not starting from A72.2. I'm a bit confused 🤣
 

Attachments

·
Registered
Joined
·
809 Posts
When guys replaced radio (was MV059 firmware, new MV080 so required updates in theory) in my 10 Apr 2018 built car in late Feb 2019, I had already required BSM firmware (from factory at ver 8401) and AMP, IPC and BCM update shown in Dec 2018 and got these as well before radio change. Radio was fitted, all was working fine. Then I read service news about need of updating the modules. I checked with MES< and identified that my PAM/LBSS/RBSS are not at versions required by service news. However all worked fine. In May 2019 I was at 15kkm service, new updates shown up, another BCM, ECU, and required PAM and L/RBSS. All was programmed in except LBSS which in theory was programmed OK but did not switched firmware, and each time was back on old rev and showing need of update. Still, car was working fine including left blind spot which didn't update. Just yesterday I was to change oil (I do it every 7.5kkm), this time LBSS went in OK - no change in operation noticed.

I suspect that AR have tested newer radios with specific base setup of related modules, and so they issue updates. Go to dealer, and with new firmware updates should show up. I do not treat it as critical though - I guess it may at worse cause some minor issues with presenting some of informations from mentioned modules at radio. None of the module does any critical function as well.
 

·
Premium Member
Joined
·
7,097 Posts
Discussion Starter #45
When guys replaced radio (was MV059 firmware, new MV080 so required updates in theory) in my 10 Apr 2018 built car ......l.
Others have seemingly updated the firmware without problems as well ......
 

·
Premium Member
Joined
·
7,097 Posts
Discussion Starter #46
Sorry but...i was reading the v85 technical specs and I'm thinking about this paragraph (see attachment). If I start the upgrade from 051,then i go to 056 and then I decide to put on 085, could something mess up? Because I don't understand if it is necessary to reprogram the other modules (AMP, BSM, IPC, PAM, LBSS, RBSS, BCM). They would remain untouched. The car is over April '18 but with oldest firmware, not starting from A72.2. I'm a bit confused 🤣
It's up to you of course, but others have apparently updated without any problems. You don't have to do it sequentially by the way (who knows what versions were in between ;) ), you can just go directly to 085.x.x
I could immagine if you don't update the firmware of the additional modules as recommended (yet), certain new functionalities might not work...
However, experience of others seem to indicate no problems.
 

·
Registered
Joined
·
10 Posts
It's up to you of course, but others have apparently updated without any problems. You don't have to do it sequentially by the way (who knows what versions were in between ;) ), you can just go directly to 085.x.x
I could immagine if you don't update the firmware of the additional modules as recommended (yet), certain new functionalities might not work...
However, experience of others seem to indicate no problems.
Can i use 4Gb USB stick? because i don't have a key with 16Gb :rofl:
 

·
Premium Member
Joined
·
7,097 Posts
Discussion Starter #48
Can i use 4Gb USB stick? because i don't have a key with 16Gb :rofl:
Doesn't matter, as long as the required files fit. Should be fine for the firmware update.
Wouldn't be large enough for the maps, as they are approx 10 Gb for the 8.8" system ;)
 

·
Registered
Joined
·
9 Posts
Another thing I've noticed with the 085 update: with my previous versions (051 en 056) the gps makes often very strange decissions when it need to recalculate the route after you was deviated from the original route. Now it seems to work normal.
So if you can, it's definitly worth to update to 085. Many things seem to be improved
 

·
Registered
Joined
·
10 Posts
DONE! all seems working great!
Good, congratulatons
Thanks :D Now i should be able to have AA (but still disable on software side) right? Maybe i could go to Eng-Custom for enable it

With 085 I'm noticing also a better reading fuel consumption parameters and (perhaps it's a placebo) a better throttle response in all running conditions
 

·
Premium Member
Joined
·
7,097 Posts
Discussion Starter #53
Thanks :D Now i should be able to have AA (but still disable on software side) right? Maybe i could go to Eng-Custom for enable it

With 085 I'm noticing also a better reading fuel consumption parameters and (perhaps it's a placebo) a better throttle response in all running conditions
I'm 100% sure the throttle response will not have changed ;)
 

·
Premium Member
Joined
·
7,097 Posts
Discussion Starter #55
Do you know if Alfa made a sort of changelog about updates?
No. At least not known to the general public, I would hope they do have one internally ;)
There is some info in this thread, and some in the bulletins....
 

·
Registered
Joined
·
8 Posts
I tried the older version software update. Didn't get far before the attached message came up...
now cant do anything and cant switch it off, even when I turn the engine off. worried that the battery (which had already been acting up) will be flat very soon. Tried to get help from the 2 local dealers, Arnold Clark in Linwood and Western Alfa in Glasgow, but both have their Alfa specialists on holiday.
Hop you can help.
 

Attachments

·
Registered
Joined
·
809 Posts
one option is to put stick with newer (or the same as was loaded last time) version of firmware. if that does not work I woudl disconnect the battery and let it boot again . knowing how things shoudl be design (and are in most of decent hardware) golden version of firmware exist and will be loaded radio probably needs just hard reset to do the check and act. properly designed systems are roboust for fails in firmware update.
If that fails, is your car on warranty? if so go to dealer you didn't call yet, and tell them that radio stopped working. either they will find the way to make it operational or you will get brand new with top version of firmware, so you won't have any reason to complain (especially if your car had 1st gen radio, you will get 2nd gen, so you will gain smoother operation and possibility of retrofitting Android Auto and Car Play).
 

·
Premium Member
Joined
·
7,097 Posts
Discussion Starter #58
I tried the older version software update. Didn't get far before the attached message came up...
now cant do anything and cant switch it off, even when I turn the engine off. worried that the battery (which had already been acting up) will be flat very soon. Tried to get help from the 2 local dealers, Arnold Clark in Linwood and Western Alfa in Glasgow, but both have their Alfa specialists on holiday.
Hop you can help.
what did you have, and what did you (try to) update with ?
 

·
Registered
Joined
·
8 Posts
one option is to put stick with newer (or the same as was loaded last time) version of firmware. if that does not work I woudl disconnect the battery and let it boot again . knowing how things shoudl be design (and are in most of decent hardware) golden version of firmware exist and will be loaded radio probably needs just hard reset to do the check and act. properly designed systems are roboust for fails in firmware update.
If that fails, is your car on warranty? if so go to dealer you didn't call yet, and tell them that radio stopped working. either they will find the way to make it operational or you will get brand new with top version of firmware, so you won't have any reason to complain (especially if your car had 1st gen radio, you will get 2nd gen, so you will gain smoother operation and possibility of retrofitting Android Auto and Car Play).
thanks. I tried using the stick again but the system won't respond to anything. I'll try the battery disconnection in the morning. I fear the battery will be flat by then though.
 
41 - 60 of 163 Posts
Top