Alfa Romeo Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
212 Posts
Discussion Starter #1
Hello all..

How does the wiper blade 'frame' stay attached to the 'wiper arm' (i.e the arm with the cable for the water, that starts just under the bonnet).
The wiper arm has a hook on the end of it that goes into the wiper blade frame, but is there supposed to be a clasp or something to actually secure this? There isn't on mine. I am sure that the pressure of the contact will hold it in place ( gulp).

Hope you understand my technical description!

Cheers
Goose
 

·
Registered
Joined
·
212 Posts
Discussion Starter #3
Thanks Jim, the actual blades are held on with cable ties too, I'll look to put some cable ties on the main wiper arms too.
Cheers
Goose
 

·
Registered
Joined
·
2,116 Posts
The original clips are so fragile and just crumble with age/uv exposure and they don't seem to be available as a separate item, you have to buy the whole assembly.
 

·
Registered
Joined
·
954 Posts
If the clips have fallen apart it probably means the wipers themselves must be pretty ancient.
I would be inclined to treat her to a nice new pair of wipers, which come complete with the correct fittings.
 

·
Registered
Joined
·
212 Posts
Discussion Starter #6
Basically I asked my question in anticipation because after my MOT, the garage put on some new wiperblades. Traveling home after it wasn't raining so I didn't use them. Then when 'driving somewhere for Xmas' it was raining, low and behold, the garage had fitted the wrong type of wiperblade, so one just came lose and was unusable. Lucky it was raining when I set out and saw the failure. Cable ties came to the rescue.

So the car left the garage, actually probaly not able to pass the MOT!

CHeers
Goose
 
1 - 7 of 7 Posts
Top