Alfa Romeo Forum banner

1 - 20 of 58 Posts

·
Registered
Joined
·
53 Posts
Discussion Starter #1
hi there ,
I am new to this forum and to being an alfa owner.I today purchased an alfa 156 2.0 TS and already am having problems ,see below

It takes ages to warm up 20mins,when warm and pulling away it struggles like hell for fuel you have to rev the boobs off it !! Once going the temp drops right down off the gauge and every time you slow down or change gear it hunts for fuel and jerks about this is not marmal even with my limited knowledge of cars!!

guy i bought it from said he thought it could be ciold start sensor or thermostat but i am not so sure?

HELP
 
C

·
Guest
Joined
·
0 Posts
Any warning lights? I would look at normal things like dodgy thermo,maf,lambda
 

·
Registered
Joined
·
53 Posts
Discussion Starter #3
Hi chris thanks for reply, no warning lights although when it starts jumping the injector light comes on its like its getting to much or not enough fuel?
 

·
Registered
Joined
·
123 Posts
Thermostat will be causing the cold running.

The low power when pulling away could be a few things, but id say MAF. As chris says, are there any warning lights? if so the ECU will have logged a fault code.

In any case, get a new thermostat fitted and a new sensor (only £8 extra) and see how it behaves.

:)
 

·
Registered
Joined
·
144 Posts
Hi andy
for a start, your car sounds like it needs a new thermostat to sort out temperature problems. secondly it needs a alfa diag to see if your maf or lamda sensors ar duff. because of the nature of the cold running problem, this will make things worse. its usually the maf that need replacing but you do need a diagnostic so you dont throw and waste money at it.
 

·
Registered
Joined
·
144 Posts
Thermostat will be causing the cold running.

The low power when pulling away could be a few things, but id say MAF. As chris says, are there any warning lights? if so the ECU will have logged a fault code.

In any case, get a new thermostat fitted and a new sensor (only £8 extra) and see how it behaves.

:)
you got there before me fella!:p
 

·
Registered
Joined
·
9,912 Posts
hi there ,
I am new to this forum and to being an alfa owner.I today purchased an alfa 156 2.0 TS and already am having problems ,see below

It takes ages to warm up 20mins,when warm and pulling away it struggles like hell for fuel you have to rev the boobs off it !! Once going the temp drops right down off the gauge and every time you slow down or change gear it hunts for fuel and jerks about this is not marmal even with my limited knowledge of cars!!

guy i bought it from said he thought it could be ciold start sensor or thermostat but i am not so sure?

HELP
first of all did you buy it private or through a trader
 

·
Registered
Joined
·
53 Posts
Discussion Starter #8
Thanks guys , seems to defo be a thermostat prob reading the other posts but will get a diag done as well, What is a MAF? I love the car and the sound is fantastic when its running!!! I have always wanted one and will not let it beat me unless its gonna cost a fortune ofcourse!
 

·
Registered
Joined
·
53 Posts
Discussion Starter #11
Gotta be honest the guy did say he thought it needed a new cold start sensor but also that it run fine when warm,which it does till you get moving then temp shoots down and car strts playing up !!
 
C

·
Guest
Joined
·
0 Posts
I would get a decent Alfa mechanic to give it the once over in that case :thumbs:
 

·
Registered
Joined
·
6,811 Posts
Hi chris thanks for reply, no warning lights although when it starts jumping the injector light comes on its like its getting to much or not enough fuel?
the injector light is the warning light on the older models;), maf or lambda:thumbs:

but a sesion on a diag machine, or if somebody is close with alfa diag, they could do it for beer:lol: then you would know for sure:D

and yeah as stated, running cold is the thermostat:thumbs:
 

·
Registered
Joined
·
9,912 Posts
fair does as lads say replace thermostat and even sender unit and if problem persists like it probably will get diagnostic done on it:)
 

·
Registered
Joined
·
6,811 Posts
my money is on maf sensor
yep, maf and thermometer:thumbs:

andy, keep an eye on your oil too, weekly checks and the water. we dont want another, TS engine mashed to bits;):thumbs:

dont worry if it seems to be using a bit. 1ltr every 1k miles is perfectly normal:thumbs:
 
1 - 20 of 58 Posts
Top