Alfa Romeo Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
158 Posts
Discussion Starter #1
Hi,

I'm begining to dispair! Had a new EGR valve fitted this morning to try and cure the awful juddering and stuttering I've been experiencing during regens. No idea whether this has worked yet but fingers crossed.

However - I now seem to have a new problem in that under light throttle the car seems to be missing a beat. I've read a lot on here and most people mention the EGR in relation to this. Could the garage (main dealer, so should know what they're doing) have messed up at all? Seems strange that this problem would develop when the EGR has been 'messed with'!

Any ideas? Really regretting going for a diesel......:cry:
 

·
Registered
Joined
·
158 Posts
Discussion Starter #3
Cloverleaf - I like your thinking, se the other topic I posted earlier today!
I would still like to know why having a brand new EGR valve fitted today has created a new problem though? You'd have thought it would have improved things???
 

·
Premium Member
Joined
·
1,848 Posts
Manc I had exactly the same issue as you. In trying to squeeze more mpg out of my 1.9 I changed EGR as recommended by an alfa mechanic only to find it had developed the dreaded low rpm judder which wasnt there before. I wondered if my previois egr wasn't effective as it could be and was masking further issues :confused:

I managed to minimise the judder with the use of the EGR restrictive gaskets on ingress and egress ports on EGR but it was never completely erradicated.

However I have recently paid a visit to alfatuner and had the egr / dpf removed / deleted and its transformed the car :D

:thumbs:
 

·
Registered
Joined
·
146 Posts
hi you require the modified exhaust valves which have a scrapper built in to the stem to stop the valves sticking during a regen when i worked for an alfa main dealer in bournemouth i carried out a few.I also worked for saab/vauxhall and i carried out loads whilst i worked there hope that helps
 

·
Registered
Joined
·
158 Posts
Discussion Starter #7
MancDave, I'm beginning to suspect you're bringing your car to the wrong stealer...
Absolutely - I wouldn't touch them with a bargepole if it weren't for the remaining couple of months warranty (not that that is worth the paper its written on - if it was on paper that is, apparently its 'standard practise' now not to supply the customer with details of the warranty and provide no details of what is/isn't covered!). I normally take my cars to alfatech in Huddersfield. Can't recommend them highly enough.

Car booked in again on Monday AM - and will be ringing Gus at Alfatune in the next week or so to discuss my options.:p
 

·
Registered
Joined
·
158 Posts
Discussion Starter #8
Quick update as I seem to be drawing a blank on this one.

The hesitation seems to be getting progressively worse. If I ease off the accelerator at say 30 mph in 3rd gear and then immediately apply a little throttle again the car will hesitate and 'bunny hop' for a second or so at around 1500 - 1800 rpm.

Not sure if this is connected but the fuel consumption seems to have dropped through the floor, but this might be down to me hanging on to gears longer and accelerating harder to minimise the hesitation.

Could the new EGR that was fitted be faulty I wonder? Or is this likely to be something else - perhaps the mechanic knocked something or forgot to plug a wire back in or something along those lines??
 

·
Registered
Joined
·
84 Posts
small bore pipe split or may have come off the turbo.

Hi this happened to my zafira cdti 150 i had a call out for an other issue and the AA repair man found that asmall bore pipe off the turbo had split. I dont know exactly where as he was underneeth the car not me, He replaced the last 6" with some rubber pipe as the origional was hard plastic.he knew what to look for as he had done a few he told me. It cured the problem. It happend as you described letting off throttle at low speed and then re applying the throttle there was like an engine hick up. I also had like a miss fire sometimes at part throttle My EGR was changed for that under warranty but that didnt cure it. Infact it was exactloy the same. My car had that problem still after a remap and an DPF delete too. so a chance AA call out solved it.

This will be a pig to check on alfa 159 due to the undertray having to come off! saying that if its like mine it needs to come off and all the screws / bolts greasing as Alfa dealers dont seem to have grease!

I have a full service history 72k ex fleet car serviced and stamped at local alfa dealers in flintshire and when I changed the air filter there were feathers, 1 dozen or so oak leaves, moths and other insects as well as dirt and dust galore! but had a service stamp from the alfa main dealer 1,200 miles earlyer ?? strange thing is that was february 2011 and the leaves fall in the autum ?? the car was on the indoors for 8 weeks from where i bought ??

there is lots of surface rust underneeth on suspension parts on my car too, will have to sort out and treat it asap.

Anyway sorry to rattle on hope the info on the pipe might help.

Mark flintshire
 
1 - 9 of 9 Posts
Top