Alfa Romeo Forum banner

1 - 20 of 24 Posts

·
Registered
Joined
·
854 Posts
Discussion Starter #1
Gents,
I've had a quick scan through previous posts but cant see what I'm looking for. I went out to the car this morning tried the blipper and nothing happened, The batteries in the blipper are not that old, nothing happened. I tried a few more times,still nothing so I trierd the spare key, still nothing. I then opened the driver door with the key and set the alarm off. The car started fine the day before yesterday, the car battery is a year old and turned the engine over fine the other day. Is there a methodical way to find out how to remedy this. I'm pretty desperate!
Your thoughts as ever will be appreciated.
CP
 

·
Registered
Joined
·
854 Posts
Discussion Starter #2
If the car battery is flat, is there anything i need to do before removing it to charge it up? Any thoughts?
 

·
Registered
Joined
·
11,604 Posts
Might sound odd, but try moving round the car while pressing the remote, think the reciever for alarm is in the rear pillar (could be wrong) - does the code light go out if the key is inserted & turned to MAR?
 

·
Registered
Joined
·
11,604 Posts
Ideally remove the battery, but as a minimum I'd remove the negative before charging - do you have the stereo code?
 

·
Registered
Joined
·
30,081 Posts
I think the receiver in the saloon is under the rear parcel shelf near the 3rd brake light.
 

·
Registered
Joined
·
11,604 Posts
I'm confusing it with the radio ariel booster thingy I think :eek:
 

·
Registered
Joined
·
854 Posts
Discussion Starter #7
1of1 Ive got the code card in the handbook wallet,Ive tried walking around the car just now,still nothing. If I open the door with the key manually the alarm goes off. Ive turned the key in the ignition to MAR, the red alarm activated light in the middle of the dash still blinks.
 

·
Registered
Joined
·
11,604 Posts
Does the code light (immobiliser) turn on then off when key is inserted & turned to MAR? (not the alarm LED) - I'd stick the battery on charge if it were me anyhoo.
 
D

·
Guest
Joined
·
0 Posts
The code and alarm systems are completely separate on a 156. So is it only that you cant turn off alarm or is your code light on dash remaining lit ?
 

·
Registered
Joined
·
854 Posts
Discussion Starter #11
Doh! apologies, ive found it. It says in the handbook that if the code light and the engine management light stay on together the code has not been recognised. I'll go and have another look. If that fails is there any special procedure for removing/ replacing the car battery if Im going to bung it on charge? Thanks for your help on this chaps :)
 

·
Registered
Joined
·
854 Posts
Discussion Starter #12
No, the code light is not on at all even with the key in and turned to mar, the airbag and abs light are,but very dim
 

·
Registered
Joined
·
11,604 Posts
Charge battery I reckon, like said ideally remove it completely, but I rarely bother. Just remove the negative terminal, attach charger & turn on.
 

·
Registered
Joined
·
11,604 Posts
Can I just remove the car battery and see if its flat and recharge it ?
I reckon that will sort it, Alfa's are particular about having a juiced up battery, the frost over the weekend killed mine, car opended OK, all electrics working, but wouldn't start, the stereo stayed on when the car was locked & the boot wouldn't open :lol:
 

·
Registered
Joined
·
854 Posts
Discussion Starter #17
The alarm is still going off with the negative terminal removed. Just to recap in case Ive missed anything.
The alarm will not deactivate with the blipper.
The code light is not illuminated.
The alarm continues even with the negative removed.
I tried opening the door manually and inserting the key very quickly, this deactivated the alarm but as soon as the key was turned to MAR it set the alarm off again.
All this time the code light has not illuminated at all.
Any more ideas gents ?
 

·
Registered
Joined
·
11,604 Posts
Weird :confused: - dunno what else to say, sorry.

Ironically mine is on charge now, new battery time methinks...
 

·
Registered
Joined
·
854 Posts
Discussion Starter #19
I'll try to remove the battery without setting off the alarm and charge it, if not i'll get a new battery. Im hoping its just a flat battery :)
 

·
Registered
Joined
·
30,081 Posts
Have you checked the battery voltage?
(and don't just say it has 12V written on it...!)
 
1 - 20 of 24 Posts
Top