Alfa Romeo Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
hi guys , ive got a few problems with my electrics - can you help
these things have just stoped working al of a sudden and there was a burning smell

head lights
indicators
electric windows
rear window heater button
air recirculating button
everything else seems fine
i have checked evey fuse
whats my next step ?????
are all these connected some how? what should i be looking for ?
any ideas ??

regards andre
 

·
Registered
Joined
·
871 Posts
The only thing that could come to mind is the wires behind the fuse box, as this blessed weather has came the rear screen heater, has been on more, common prob in a Gtv rear screen heating probs, could have melted some wires behind, other than that how's the fuse box looking ?
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4
hi and thanks for the speedy reply ! :thumbs:
i had the fusebox in my hand and it looks fine behind, i havent checked fuses under bonnet but i have in the boot and there ok , what do the fuses under the bonnet do are they connected ,ill go out and have a look
what is worrying me is the burning smell ,
 

·
Registered
Joined
·
8 Posts
Discussion Starter #5
right then , i have checked the fuses under the bonnet and all looks good ,
th interia light works and the hazzard lights and brake lights work but all the other things i have mentioned dont ?
 

·
Registered
Joined
·
871 Posts
Very strange, sounds like there is a serios wireing issue to be honest, so either get tracing or book into an auto electrician,
 

·
Registered
Joined
·
8 Posts
Discussion Starter #7
i have now come in from checking all the wiring and testing , it seemed power wasnt going round all the fuse box but it didnt look melted anyware so i have just opend it up and there is a burn in the circuits at 2 points , its got to be that surley !!!! new box i think :thumbs:
 
D

·
Guest
Joined
·
0 Posts
the timer probaly gave up on the heated rear screen relay which means it was on all the time, this has prob melted something in the interior fusebox, will explain the melted fuse common fault unfortunately.
 
1 - 8 of 8 Posts
Top