Alfa Romeo Forum banner

21 - 40 of 702 Posts

·
Registered
Joined
·
18 Posts
I've managed to update Connect Nav+ system to 5.0 in my AR 147 (2006) and it now plays MP3's!!!*

There are rumours that 5.2 is out? Anybody knows something about it?

If someone is interested in upgrade let me know and i will tell you how i made it.

Upgrades are for alfa 147 and probably gt from 2004+ on with 5.xx upgrade, older models are availible with 26.xx update**


*VR doesn't work in english (works all other languages). Don't know why

** We didn't manage to update GT 2004, and update cd stucked in player, so i don't advise you to upgrade it, until someone suceedes with it.

Take care (for Alfas ofcourse ;)),
wodp
 

·
Registered
Joined
·
69 Posts
Hi, been following this thread fro ages now! do i have to take my car to the dealers to get this done? or is it possible to download the update from somewhere?

Cheers,
Rene
 

·
Registered
Joined
·
370 Posts
Hi, been following this thread fro ages now! do i have to take my car to the dealers to get this done? or is it possible to download the update from somewhere?

Cheers,
Rene

Me too! Keen to know where/how to get this done for my 2003 147 Connect+. Latest problem I've got with her is that the volume on the satnav voice is ridiculously loud! Anyone know how to turn it down? I'm having to just mute it permanently.

J.
 

·
Registered
Joined
·
69 Posts
i THINK you can change it when shes talking. Just use the controls on the wheel.
 

·
Registered
Joined
·
18 Posts
Hi, been following this thread fro ages now! do i have to take my car to the dealers to get this done? or is it possible to download the update from somewhere?

Cheers,
Rene
It's possible to get it, but don't know where.
I have it on my pc and don't know if can be posted here.

Who wants setup cd and software updater let me know on pm or mail matej (a) trije (dOt) com - rather on mail, becouse i have trouble logging to AO forum (don't know why, but need to reset my pass everytime...).

Take care,
M.
 

·
Registered
Joined
·
69 Posts
Hi, you can take a ISO image of the disk (or if you already have it stored on your PC then no need) basically its just a copy of the disk! Then upload the file to something like RapidShare: 1-Click Webhosting then that’s it we can all download it from that site!

If none of that makes sense let me know I can explain in more detail!

Cheers,
Rene
 

·
Registered
Joined
·
30,408 Posts
I would just like to add my interest to this. I really want to get Aux in sound working - I have got the cd changer Aux in adaptor but it doesnt seem to recognise when its connected. Anyone know if an update might fix this??
 

·
Registered
Joined
·
18 Posts
Ok this is how i made.
First i need to say that you're doing everything on your own risk!!

I have 2006 Alfa 147 and it works on Connect Nav+. Friend tried on earlier 2003 version and it didn't work on his (Cd stucked in player!).

I warn you... it's your decision.

1. check your current firmware version
Help here:http://www.ihlems.de/alfa/connect_info_en.html

2. if it's x.yy it's newer system, older have xx.yy
I had 4.07 and updated to 5.0 (MP3 support)

3. my car was turned off while updating, so turn on only CNS (connect nav sys) and insert update cd.

- update cd for x.yy (newer system can be downloadad from this location:
http://www.2shared.com/file/3137907/9a9e1a5a/Firmware_Connect_Nav_alfa_147_mp3_-_MP500.html
Password: alfaklubsi

Older version is here:
http://www.2shared.com/file/3138442/de23a8d4/Navtech_alfa_147_connect_update_2316.html
Password: alfaklubsi - BUT I WARN YOU... My friend couldn't upgrade and he had serious problems with it!! If someone has sucessfully updated please share with us!

- burn iso with some burner (i used nero - at lowest speed and DAO: disc at once)

4. insert cd and you get error cd message (radio can't play it, that's normal).

5. restart CNS with cd left in.

6. it should boot from it now and start updating process.



! Few times it got to 50% and it looked that it's stucked. I tried everything to remove cd and cancel update. Than when i almost lost my nerves, i just left it to cycle and restart CNS again and again... After 20minutes when i got back in the car it vas already 70% and than 90% and finally finished. Cd got out itself!

7. after cd out, restart CNS and wait some time.
(first boot is much longer than usual)

8. Than i tried MP3 cd:



... and checked FW version:



Update was sucessful.

WARNING: after updating i couldn't change VR (voice recognition) language to English, all others work (French, German,Dutch, Italian, Spanish...) Just ENG not.

There are some informations about even newer SW version 5.2 which would repair this and also allow to skip songs for more than one a time.

To skip more songs, i use shuffle.
Also 5.2 should have improved when you turn on car, it goes from where you've stopped before. It's annoying to always start at song 1 on mp3 cd!!
I hope they will fix such small but stupid software problems.


DON'T BLAME ME IF YOU'LL GET FAULT ON CNS!! I just reported how i updated my CNS.

But i hope you've managed to update it.It's so nice to listen to MP3's while driving such car. Cuore sportivo ftw ;)

Regards,
M.
 

·
Registered
Joined
·
18 Posts
I would just like to add my interest to this. I really want to get Aux in sound working - I have got the cd changer Aux in adaptor but it doesnt seem to recognise when its connected. Anyone know if an update might fix this??

Sorry wouldn't know about this...
 

·
Registered
Joined
·
370 Posts
Ok this is how i made.
First i need to say that you're doing everything on your own risk!!

I have 2006 Alfa 147 and it works on Connect Nav+. Friend tried on earlier 2003 version and it didn't work on his (Cd stucked in player!).

I warn you... it's your decision.

1. check your current firmware version
Help here:http://www.ihlems.de/alfa/connect_info_en.html

2. if it's x.yy it's newer system, older have xx.yy
I had 4.07 and updated to 5.0 (MP3 support)

3. my car was turned off while updating, so turn on only CNS (connect nav sys) and insert update cd.

- update cd for x.yy (newer system can be downloadad from this location:
http://www.2shared.com/file/3137907/9a9e1a5a/Firmware_Connect_Nav_alfa_147_mp3_-_MP500.html
Password: alfaklubsi

Older version is here:
http://www.2shared.com/file/3138442/de23a8d4/Navtech_alfa_147_connect_update_2316.html
Password: alfaklubsi - BUT I WARN YOU... My friend couldn't upgrade and he had serious problems with it!! If someone has sucessfully updated please share with us!

- burn iso with some burner (i used nero - at lowest speed and DAO: disc at once)

4. insert cd and you get error cd message (radio can't play it, that's normal).

5. restart CNS with cd left in.

6. it should boot from it now and start updating process.



! Few times it got to 50% and it looked that it's stucked. I tried everything to remove cd and cancel update. Than when i almost lost my nerves, i just left it to cycle and restart CNS again and again... After 20minutes when i got back in the car it vas already 70% and than 90% and finally finished. Cd got out itself!

7. after cd out, restart CNS and wait some time.
(first boot is much longer than usual)

8. Than i tried MP3 cd:



... and checked FW version:



Update was sucessful.

WARNING: after updating i couldn't change VR (voice recognition) language to English, all others work (French, German,Dutch, Italian, Spanish...) Just ENG not.

There are some informations about even newer SW version 5.2 which would repair this and also allow to skip songs for more than one a time.

To skip more songs, i use shuffle.
Also 5.2 should have improved when you turn on car, it goes from where you've stopped before. It's annoying to always start at song 1 on mp3 cd!!
I hope they will fix such small but stupid software problems.


DON'T BLAME ME IF YOU'LL GET FAULT ON CNS!! I just reported how i updated my CNS.

But i hope you've managed to update it.It's so nice to listen to MP3's while driving such car. Cuore sportivo ftw ;)

Regards,
M.

thanks for the info but the links don't seem to be there?

Anyone tried this successfully on an Alfa 147 2002 Connect+?

What is likely to happen to my system if the upgrade fails...? :(

TIA
 

·
Registered
Joined
·
18 Posts
How to turn on html codes?

Links are:

NEW CNS SYSTEM:
2shared - file upload

OLDER ONE:
2shared - file upload

And than SETUP cd: to change language (ENG VR doesn't work)
2shared - file upload


Passwords are all the same: alfaklubsi

@Tia: cd can stuck in CNS and it won't boot up (no music in car). It's better to wait for someone to report sucess. We tried on one alfa GT 2004 system and it stucked cd (it's on servis now to get it out).

M.
 

·
Registered
Joined
·
20 Posts
Thx for the Software update as yet have not tried it. My framewire is 23.13 (52 plate)the down load file is 23.16 do we know if this is the latest framewire update
 

·
Premium Member
Joined
·
7,694 Posts
Thx for the Software update as yet have not tried it. My framewire is 23.13 (52 plate)the down load file is 23.16 do we know if this is the latest framewire update
26.15 (or 26.16?) is the latest in that range...
 

·
Registered
Joined
·
1 Posts
Hi,

yes, newest version for the "older" (probably before 2004) Connect NAV+ is 26.16

That update appears to be from 2004.

Anyone by chance knows what has been changed in 26.16 from 26.15 ?
I'm thinking about updating, but I don't want to make things worse ;)

It looks like version numbers are often confused.

The version in the second previous post from wodp for the older systems is not 23.16 as the filename says, but 26.13
Which therefore is not the newest one, which is 26.16

I hope this is helpful to anyone ;)


One more thing considering the mp3 upgrade:

As already stated, it works only if you have version 4.xx or 5.xx which is believed to apply to units from 2004 or later.
Mine is production date 2003-03 (can be seen on the same screen as the version) and still is the old 26.xx variant.

Apparently those new units had something changed on internal hardware and mp3 upgrade only works on those.
 

·
Registered
Joined
·
18 Posts
Thanks for clarification. Didn't know exactly for old systems.

Anybody knows about 5.2 update?? it should have repaired last song played and such stuff... i don't remember where i read that.

Anyone?

Take care for Alfas ;)
M.
 

·
Registered
Joined
·
32 Posts
Are any of you guys able to point me in the direction of a Connect+ 'set-up cd' disc, image or file for the 147 at all please? - one which WILL allow me to change the language back to english aswell.

We have been trying to find where the master code is stored in these units for the last 9 weeks (seems to be in one of the secured BGA flash devices) and every 3 or 4 attempts to read, modify, re-read the data, results in the unit reverting back to Italian language.

I am aware that the launguge can be changed via the dash mounted computer but this can only be done after the unit has been 'married' to a car with the master code :rolleyes:

Doesn't have to be a freebie, more than happy to pay for it if somebody knows the link :)

Thanks in advance
 

·
Registered
Joined
·
1 Posts
For those of you with updates that fail, there is a procedure that works on Fiat Connect Nav's and probably Alfa's too (but I have not tried) to restart it. Turn the unit on after it has failed and press 2, 3, 4, 5, 6, TEL and the display lights should flash 3 times, then update will restart.
 

·
Registered
Joined
·
609 Posts
Nice info on here. When I get my car, hopefully on Saturday, I'll try and get to Mango's and see if they'll update the Connect Nav+ for free. If they will, I'll somehow try and 'borrow' the CD and image it on my laptop.
 
21 - 40 of 702 Posts
Top