Alfa Romeo Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Hey guys, so I have a 1985 Alfetta 2.0. It was the top of the range version with air con and electric windows and fuel injection.

Anyway, the fuel injection system broke completely and is thrown away, carbs were put on, but the only issue is I could only get a 42 and a 40 weber. They also have different emulsion tubes. And they all use 138 main jets.

I am a student so can't always afford new parts, it's tough lol. But I will not sell my car for the world. I have put 100s of hours into the body and paint and it is my old faithful.

The issue is I am only getting 7km/l and can't afford it going at that consumption.

It drives very nicely, I absolutely love driving her, but it does backfire when freewheeling/coasting in gear. Has that got something to Do with the bad consumption?

I should be getting 10-12km/l so I would really like some help in what needs to change to get her running lighter.

Please any advice appreciated, and gladly accepted. Bear in mind that I am a student so please don't tell me to go buy new emulsion tubes etc unless you know 100% that is the problem and is taking 3-5km/l from me.

The fuel pump is a very low pressure electric pump, and the needle and seats are all 100%


Thanks very much
Joel
 

·
Registered
Joined
·
6,004 Posts
Hey Joel,

Yeah it sounds like the carbs are over fueling dramatically. I think you have to re-jet. But it will be VERY tricky to try balance offset carbs 40's and 42's - try get the same... But to what and how to do that is pre my knowledge.

I think you'll get better responses from the classics lounge:
The Classic Alfa Romeos - Alfa Romeo Forum

EDIT: I see you have posted it there and have some responses
 
1 - 2 of 2 Posts
Top