Alfa Romeo Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
221 Posts
Discussion Starter #1
Chaps,

Having looked in both early workshop manual, and hand book, I cannot find the relay for the front fog-lights...

Can anyone help me ??
 

·
Registered
Joined
·
1,466 Posts
Thought the relays were in 3 locations - fuse box, in the boot over he battery & on 3 brackets off the front memebr under the bonnet.

My bet would've been in the fuse box - at least there you have a label to tell you what's what.
 

·
Registered
Joined
·
221 Posts
Discussion Starter #3
Thanks for reply :)

Nope, there is a load under the drivers Facia, and even more under the passengers. :confused:

I have checked fusebox ones , plus the ones under the bonnet :- no luck !

The light comes on when i press the button for the lights, but not even a click from the relay, so I cant even hear where-abouts it may be :rolleyes:

Woe is me
 
M

·
Guest
Joined
·
0 Posts
Found it for you. It's on the UK passengers side, at the bottom, roughly where your toes would be. Makes a clearly audible "click" on and "ping" off.

Don't want to teach granny how to suck eggs but check ignition on and lights on beforetrying fog lamp switch.

Look in passenger footwell for a plastic cover held by two nyloc nuts. Remove the cover. Without having actually removed the cover, I felt up round behind this cover and along to the right, nearest to black metal cover (that does I-don't-know-what) by the tunnel. You can feel the rectangular relay body and I could feel it clicking too - when it works that is!

HTH

PS if you need pic, pls let me know
 

·
Registered
Joined
·
221 Posts
Discussion Starter #6
Thank-you both :)

Found them where you said :-

The reason it aint working is because the relay has been taken out :mad:

Put on in and off they go :)

Cheers guys
 
1 - 6 of 6 Posts
Top