Alfa Romeo Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1
first I would like to thank anyone who recently gave advice on my gear probs .was very useful and now gears are changing fine .
no sooner did i have it fixed when ,driving back from the garage the car just suddenly stops . True, the fuel light is on but Ah think there is still enough in tank .battery did not take long to drain . In the event of fuel starvation is there any way Ah can get fuel into the system ?
 

·
Registered
Joined
·
9,912 Posts
i would make sure fuel is topped up first,turn key to mar then off and then to mar then crank engine over ,should start,if not prob crank sensor
 

·
Registered
Joined
·
26 Posts
Discussion Starter #5
cheers for the info lads ( great wee thing this forum) .Did as you`s suggested . Got the temperamental pest goin . Seems that it could be the sensor that you both mentioned . Where is it ? is it accessible ? One thing of note ; my control system warning light had come on when Ah got the car goin . Bearing in mind that you `s said it could be a sensor , Ah stopped ,turned off ign , lifted the bonnet and shook the engine . when Ah started her up again ........ the warning light was gone !! woohoo ah said after "thank f***".
 

·
Registered
Joined
·
26 Posts
Discussion Starter #6
ps meant to say . checked some other forums regarding crank sensor .Seems that it can start goin mental wen it heats up . Quite like ma other lovely pest . .her name is audrey and a human ........ sometimes
 

·
Registered
Joined
·
6,274 Posts
It's in the engine block, under the starter motor. Held in by one allen key bolt, and it's the brown connector under the engine cover.

Got a few spare if you want one, but they're only about £20 new.
 
1 - 8 of 8 Posts
Top