Alfa Romeo Forum banner
1 - 17 of 17 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi everyone,

Just got myself a 1983 Spider and thought I may be in need of help/advice in the future.
First ever Alfa , First ever soft top . And it has rained most days since it arrived Ho-Hum .
Plenty of fettling to do on it but nothing too major - at least that i have discovered yet!
 

·
Registered
Joined
·
14,575 Posts
Hello and welcome mate! Good luck with the project, any questions someone on here is bound to know they are a very knowledge bunch except me!

Enjoy:D
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Hi,
Thanks for the support - seems a friendly place.
I have been running modern (=boring) cars for the last 10+ yrs , so it is good to get back in the garage with something that does not need a computer to diagnose its faults
First thing is to try and get the heater working . I am sure it got 10deg colder since I went for a test drive in it 2 weeks ago.

Oily fingers for me
 

·
Registered
Joined
·
14,575 Posts
Definatly getting colder mate and its only going to get worse. They said on the radio earlier that it was only going to be 11 degrees tonight:rolleyes:
 

·
Registered
Joined
·
867 Posts
Hi there & Welcome! :p

There are a lot of very knowledgeable people on this site.

I'm not one of them! :cry:
 

·
Registered
Joined
·
32,442 Posts
hello :)
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #14 ·
Thanks so much for the friendly welcome

Typing with freezing fingers - as I have just come in from fixing the heater motor. I had forgotten how much I enjoy working upside down underneath dashboards!:rolleyes:
Motor was all corroded , but stripped - cleaned - brushes resoldered and it is working fine now . Now lets see if I can remember how it all goes back together.

Pics? coming soon - need some sun to show it at its best.
 

·
Premium Member
Joined
·
42,930 Posts
Hello and welcome to AO..........:)
 
1 - 17 of 17 Posts
Top