Alfa Romeo Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I've just joined the forum, not sure what to expect yet but, we'll see what happens!
But, as a first step, I thought I should introduce myself....
I've been driving Alfas for some years now, initially a friend had an 1978 S-reg 1300 Sud, I then bought a tatty 1984 B-reg 1500 33 (B15 LBJ - from another mate). Later, I built myself a lovely 1978 S-reg series 1 Alfa Sud Sprint (WNR 447S - bought as a part finished restoration but I had to redo an awful lot!). I'd always had a suspicion that it was the oldest one left on the road but, I've never been able to confirm this, it had left the factory as a 1300sc but, I gave it a 1500 race engine & a close ratio gearbox. I now have a 2000 X-reg 156 Sportswagon (X484 FDB). Meanwhile I've built several race cars (33s) for the Chris Knott (as was) Alfa Championship. I never got to race though, I built them with a mate who has all the fun! I can't hold a race licence. I have epilepsy which bans you from the road for a year - which is bad enough - but, it bans you from the track for ten years! (I've just found out that although the year off the road is counted from the date of the seizure, the ten years from the track is counted from when you stop taking the medication! - I'm likely to be on it for life!). He won his class (F) a few years ago, we moved in to another championship (single seaters) for a while but, we are currently building a 3L GTV for him to race in the ARCA championship next year.
I should perhaps explain my user name too, I'm also into old British cars, I have had three Rover P6's, the first I bought from a scrap yard, a 2200TC (KBY 283P). I “tarted” it through an MOT, drove it for a few hundred miles until it went “BANG – Tinkle Tinkle Tinkle”, throwing a con rod through the side of the block! It subsequently went back to the scrap yard but, while I had it, a mate pointed out that - given that it had a black vinyl roof - it might look cool as a convertible. Some years later I bought another, a 2000SC (BMR 792L), welded the back doors shut, strengthened the sills & cut the roof off! I lost touch with the car because I had to sell it rather quickly when I moved house having lost my job. I saw it for sale about 10 years later so that proves that my self-taught welding must be OK! I've now bought myself a 1972 V8 (VPO 714K) which is finally nearing an MOT! I'm thinking of turning it into a track day car - I can drive on the track on track days, I just not allowed to drive competitively. Rover built several racers back in the 60's & 70's, I thought a replica might be fun! Incidentally they commissioned two convertibles too.
But, we're here to talk about Alfas! My 156 has had a problem running when cold ever since I bought it. It had a full service history when came to me so I thought I should keep it up. There is a chap here in my village who started a company servicing Alfas so, I've been taking it to him. I was talking to one of his mechanics who suggested, having driven the car, that the Air Mass Flow Sensor might be playing up. Alfa, he told me, charge about £200 for this & that I'd be better off buying a replacement over the web. This I did, for about £70. I fitted it yesterday, it transformed the car instantly! It now pulls from tick-over & has lost the “flat spots” that I hadn't even realised were there!
The only thing now is that it doesn't idle very well. I'm told that this is likely to be the engine ECU still trying to compensate for the duff Air Mass Flow Sensor and that I need to reset it. I think I've found out how to do this from your forum: Ignition on for 90 secs, ignition off for 90 secs, start the engine & leave it ticking over for 10 mins. I'll give it a try later today.
Meanwhile I'm off to see the last of the 2008 Alfa races today at Donington.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #7
Cheers for the welcome guys! Reading over my intro I now recall that my 1st 33 was actually B21 LBJ! Not B15, brain again I suppose! Actually I recall that there were quite a few 33's running around here with just two numbers in their reg, most of them were LBJ's. BJ was a Norwich reg, these all came from Station Garage in Fulbourn, just outside Cambridge. You might also have heard of RS Engineering, again in Cambridge? They built a pair of gas-flowed heads for my 1st 33 which certianly made it go better! Their mechanic Dave Ashford introduced us to the Alfa Championship initially. He now runs Brunswick Motorsport.
I tried resetting the 156 ECU as mentioned above but, while it has improved, it still doesn't idle very well. Any ideas?
 

·
Registered
Joined
·
32,440 Posts
Phew, that's some intro post :D

welcome to AO:)
 

·
Premium Member
Joined
·
42,863 Posts
hello and welcome to AO........:)
 
1 - 14 of 14 Posts
Top