Alfa Romeo Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hi,

I've just bought my first Alfa, a 2000/W Rosso Red 156 2.0 TS Selespeed. I've been driving it for a week now and love it but there are a few problems I've found so far and was wondering if anyone can help.

1, No owners manual, does anyone know where I can download one from?
2, Airbag light comes on and stays on
3, Brake warning light sometimes comes on, probably need to change the pads but haven't looked yet
4, On the rev counter a symbol like the boots open sometimes comes on and the car beeps, is this to tell me the boots open as the centre display that shows the doors and boot does not come on at this time but works as it should.

I'm already trying to source a set of cheep 16" or 17" Teledials, a rear spoiler and side skirts.
 

·
Registered
Joined
·
48 Posts
Hi there,

You'll find a multitude of threads about the dreaded airbag warning light, dodgy pin connections under the seats seem to be a common fault, but if you don't know the car I'd suggest getting it checked out. As for the brakes, like you say, you need to check! The pads are not difficult to change but are prone to getting stuck in the calipers leading to uneven wear. (Again, lots of threads on this, use the search function at the top of the forum.)The symbol in the middle of the rev counter... does it do it as you're going along? This doesn't ring any bells for me , perhaps someone else knows what it is? Manuals are often for sale on ebay. Will have a look to see if I have one kicking around. Tom
 

·
Registered
Joined
·
50 Posts
the symbol that looks like the boot and the beeping i i would guess is the selespeed light! if its on and beeping this doesnt sound to good
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
First of all thanks for the quick and helpfull replies, I will try and have a look at the airbag problem this afternoon and the brakes tomorrow at work.

Looking again at the light its now obvious its a gearbox so I would agree its the selespeed light. It only comes on now and then and only for a few seconds, I think its a loose connection as it seems to happen when I go over bumps, if not I might sell the car and replace it with a better 156 :) .

Once again thanks.
 

·
Registered
Joined
·
327 Posts
hi Tony

Try ebay for the manual/
Check connection under paddenger seat for airbag light.Check brake fluid level, if ok refer to alfaworkshop.co.uk before changing pads etc.. they have loads of usefull info on the site.
alloys- ebay.good luck
 
1 - 5 of 5 Posts
Top