Alfa Romeo Forum banner

1 - 20 of 20 Posts

·
Premium Member
Joined
·
1,991 Posts
Discussion Starter #1
Something has died between the intake fan and the matrix. Its horrible smelt like dog **** to start with but its not , cannot for the life of me find a way through to the air flow to the matrix and the fan intake motor. I understand that the smell must be in that area as there isn't anything lying on top of the matrix , looking from ythe top.
Its just minging and worse on a hot day , if you get that kind of thing in Scotland.

Al I can do is cook it and hopefully , it dries out!
Cheers Pat
 

·
Registered
Joined
·
13,236 Posts
Ah... some plucky rodent ventured in there looking for nuts, only found AlfaPat and then couldn't get out again, poor beast. :(


I have no idea where to look for it.. but I'm still curious what people suggests.. since I have a loose nut or screw in the same place by the sound of it and it rattles backwards and forwards when I go round corners (bl*ody annoying! :D)


Ralf S.
 

·
Registered
Joined
·
42,287 Posts
Remove the pollen filter and spray the evaporator with Dettol aerosol disinfectant. Twice a year service routine that I perform on her jalopy before she can have a moan. :D :lol:Works 100%. :thumbs:
 

·
Registered
Joined
·
7,120 Posts
there is no filter on a 145

access is gained under the plastic scuttle at the bottom of the windscreen, remove the cover and you can then peer down the intake tube and see the motor, which is in the passenger foot well,

pics here

Board Message

you may have to register to see the pic though

you may have a blockage in the drain holes that is allowing a build up of water, hence the foul smell, this needs to be resolved before it floods in the car.
 

·
Registered
Joined
·
42,287 Posts
What? Pongs without pollen filters and a/c.? Aha. Then the rotting leaves and other gunge with a blocked drain or dead rodent may be the cause as said. Sorry about my lack of comprehension. :):
 

·
Premium Member
Joined
·
1,991 Posts
Discussion Starter #6
Yes I have already done that and even got a long flexi probe with a claw pushed through the duct above the fan blades but sadly not long enough as its probably slighly further in and under the matrix.
Also tried through the footwell ducts but they take a different route to above the matrix but no access to fresh air duct.At a loss really ............. b****y awful to drive or live with!!
 

·
Registered
Joined
·
7,120 Posts
Hi,

sounds like its matrix out time, there is a how to on the same site, that said, any nasties must have passed through the fan first. Could just running with the heater on full for a good while kill off any bacterial build up in the matrix?
 

·
Premium Member
Joined
·
1,991 Posts
Discussion Starter #8
Well I thought of that , but I think its a little more than just bacteria but more like a bsmall bodty trying to decompose .
Although general heat on the blower side will help things along I think if like a hot air blower would help as the "varmit" is on the underside of the matrix airflow.
 

·
Premium Member
Joined
·
1,991 Posts
Discussion Starter #10
Well dash is off ,what a *****! Trying to pursuade someone to reach in with a small hand and arm , but not keen , mine is too large , looks like matrix out , but need to drain the coolant if i'm not mistaken and then prise out the matrix.
Will post the result.
 

·
Registered
Joined
·
7,120 Posts
just a thought, how about dropping the heater motor and use a flexi hose taped on the end of the vacuum cleaner to suck out whatever is in there.

HTH
 

·
Premium Member
Joined
·
1,991 Posts
Discussion Starter #12 (Edited)
Yes I might try that, I tried a flexi tool which has a grab hidden in it but never came in contact with anything, also tried my partner.s small hand but you need to have a break just above the wrist to get round to the bottom of the matrix!
So a hoover is next then matrix out if unsuccessful, I had a wee tug at the matrix to see if it would move once I removed its retaining screws and it weeped water at the inlet joint it seemed a little fragile, so I left that one out meantime.

Ok to move on I have tried a makeshift hoover and that failed , took the matrix out and all I got was leaves , I coiuld see that there was another cavity behind that and tried the hoover again , heard a change in note of the suction and hey presto , got the smelly blighter!
I am trying upload a photo but I obviously don,t know what I am supposed to do .
 

·
Registered
Joined
·
7,120 Posts
annoying little ****er

you did well to get that out, looks quite big too (or is it in close up :lol: ), looks more than a field mouse anyway. I have heard of rodents getting in cars before, barn finds and the like rather than working examples.

Hazard of rural living?
 

·
Premium Member
Joined
·
1,991 Posts
Discussion Starter #15
Yep the joys of living in the country, I think it must have gone in while the climTe was cold before the hot spell we had , then expired after two three dYs as it started to smell just after that anyway it's out and now the heater control took a jump to itself and blows cold will have to investigate tonight. I don't think the trim can tKe much more pulling off and on!
Thanks for your input by the way, much appreciated.
 

·
Registered
Joined
·
7,120 Posts
I guess not having a filter on the intake means they can get in. The filter holder is only a piece of plastic that clips over the intake, so it is cheap and easy to fit, them slide a filter in place, however I suppose they could still gnaw their way in if they are that determined. Wire mesh maybe?

HTH
 

·
Premium Member
Joined
·
1,991 Posts
Discussion Starter #17
H,mm did not know there was a cover over the blower, that makes sense now that you say it. It does look a bit exposed , its only got a water deflector so if I find a car being broken ,this should have a cover fitted the the intake housing?
The fan switch fixed now did it at lunchtime , found the geering had popped out of the switch panel moulding.
Getting there!
Its just great fun to drive , have had the car around for some time but never actually used it very seriously.
 

·
Premium Member
Joined
·
2,729 Posts
bad smell

I had a sud once that stank like rotten eggs, it was the alternator cooking the battery, just an idea.
 
1 - 20 of 20 Posts
Top