Alfa Romeo Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
543 Posts
Discussion Starter #1
I am finding that the heater blower controls, the one which increase or decrease the blower speeds freezes on a regular basis. You can press the + or - as much as you like but nothing, any ideas??
 

·
Registered
Joined
·
61 Posts
Sorry to state the ovious mate but you and I both know it shouldn't do that so i'd say it's broken. Dealer is you best call if your still under warranty.
 

·
Registered
Joined
·
543 Posts
Discussion Starter #3
They do work after a while, i have been told that it is something to do with the flap settings, climate control etc but i can not find anything in the handbook????
 

·
Registered
Joined
·
61 Posts
Bob, if they're freezing surely they're malfunctioning. Anyway I don;t think mine have never frozen and I can't recall a post on here reporting a similar problem. Have you tried a search of the forums?
 

·
Registered
Joined
·
11,159 Posts
If by frozen you mean not responding to presses of the - or + button, yes it does happen as posted above it is something to do with A/C setting, ambient air temp, whether the heated front window setting has been selected, etc . Mine often refuses to change fan speed until the engine temp has risen a bit then it is back to normal. Don't know why I can't find anything in the unintelligible A/C section of the handbook either. I would not worry as long as it works after engine warms up.
 

·
Registered
Joined
·
543 Posts
Discussion Starter #6
thanks Alfa moment, thats exactly what happened tonight. left work started engine etc 1 bar on the heater would not alter speeds, after a few minutes it worked, as you also say nothing in the handbook???
 

·
Registered
Joined
·
11,159 Posts
May just be me I found the Climate Control section of handbook as easy to understand as Ikea flatpack instructions!!:cheese: May try again,.. think my Engli-Italian is a bit rusty and got bored trying to decipher some of the text. Then again know how heater works now so maybe not!!:)
 

·
Registered
Joined
·
972 Posts
If by frozen you mean not responding to presses of the - or + button, yes it does happen as posted above it is something to do with A/C setting, ambient air temp, whether the heated front window setting has been selected, etc . Mine often refuses to change fan speed until the engine temp has risen a bit then it is back to normal. Don't know why I can't find anything in the unintelligible A/C section of the handbook either. I would not worry as long as it works after engine warms up.
Agreed. It's a case of Italian obstinacy - the Climate Control System considers that it knows best and won't allow you to turn the blower up when the engine isn't warm enough :) If you press and hold the + button for long enough it does seem to eventually get the message and do as it's told.
 

·
Registered
Joined
·
11,159 Posts
On a similar note is it possible to get the auto to turn off, with the temps still on and fan speed showing? get full auto , auto , or all off, think I did get it when weather was warmer but that was while ago wasn't it?:lol:
 

·
Registered
Joined
·
972 Posts
On a similar note is it possible to get the auto to turn off, with the temps still on and fan speed showing? get full auto , auto , or all off, think I did get it when weather was warmer but that was while ago wasn't it?:lol:
IIRC 'Auto' is Italian for 'Manual'.............

When you over-ride it from Full Auto (eg: alter the fan speen) it goes to Auto mode - it's always been a bit of a mystery to me; but I seem to remember reading on here some while back that "Auto" meant "Manual" :lol::lol:
 
N

·
Guest
Joined
·
0 Posts
I miss "full auto". I understood perfectly how
auto/full auto/none would function.

Has been fine for the past 8 1/1 years.

Now it's only "auto" or nothing in the new system. :(
 

·
Registered
Joined
·
972 Posts
I miss "full auto". I understood perfectly how
auto/full auto/none would function.

Has been fine for the past 8 1/1 years.

Now it's only "auto" or nothing in the new system. :(
Nev, isn't it just a case of "Auto" does the same as "Full Auto" used to; and nothing is the old "Auto"? I thought the Italian's must have learnt that "Auto" doesn't mean "Manual".....but that they obviously still haven't learnt to program it to say "Manual"! :lol:
 

·
Registered
Joined
·
11,159 Posts
IIRC 'Auto' is Italian for 'Manual'.............
sorry I am a bit of an ignoramus with this text talk, (my kids say I'm too old to understand it,:confused:) that may be true but what does IIRC mean, please.:)
 

·
Registered
Joined
·
11,159 Posts
Yo! You and me both mate! IIRC is one I've already had decoded by my kids though - "if I remember correctly"
God I feel old these days!! :(
When my kids talk it's like..............





It's language Jim but not as we know it!!!!!!!!!!!!!!!!:lol:
 
1 - 16 of 16 Posts
Top