Alfa Romeo Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
421 Posts
Discussion Starter #1
My headlights aren't working. I took the headlights out but they looked good so i went and only bought one bulb. Changed it over but no light. I bought some fuses to check the fuse before looking for the relay behind the glove box. Does any one have a diagram of which fuse I need to change? Its a 2001 GTV 3.0
 

·
Registered
Joined
·
421 Posts
Discussion Starter #2
Just had another look and noticed the symbols above the fuses. Looked at all the fuses for the lights and theyre ok but the one which I think is for the rear heated windscreen has melted?! So that only leaves the relays I guess? Bit dark now. Any other ideas anyone?
 

·
Registered
Joined
·
4,627 Posts
F7, F8, F9 & F10

F7 RH Dip
F8 LH Dip
F9 RH Main
F10 LH Main

All 10 Amp and all in tthe main fusebox

Relays are I49 & I50, both rated at 20 Amp. Located in the main fuse box, top & bottom ( with an unrelated relay between them ) on the left side.

Can you explain the bit about relays behind the glove box?

Common components that wouldn't require multiple points of failure is the switch on the steering column and fuse F15 ( which feeds the relay coils ).

EDIT :

Do the following work?
side lights
Instrument panel lights
rear fog lights.

EDIT 2 :
Fuse F15 is also on the main fusebox.
 

·
Registered
Joined
·
421 Posts
Discussion Starter #4
I read on another post that someone changed a relay which is for the lights behind the glove box? I havent looked for them.

The side lights, front fogs and rear fogs work. The instrument panel is fully illuminated.Its booked in with Motormech in the morning so hopefully it'll all be sorted.
 
1 - 4 of 4 Posts
Top