Alfa Romeo Forum banner

1 - 20 of 174 Posts

·
Registered
Joined
·
2,888 Posts
Discussion Starter #1
I’ve bought a reasonable Chinese head unit, everything works as it should apart from the steering wheel buttons (Volume +/- only works okay).
I have an Alfa Romeo Brera with Blue & Me (not that it should make a difference), the cable harness supplied has Key 1 wire connected but not Key 2 wire - Do I need to connect Key 2 somewhere......Where?
How do I get these steering wheel buttons to work?
It is not the case that I need to buy a connect2 harness as the one supplied should do the job.......:rofl::devious::grumpy::grumpy:
 

·
Registered
Joined
·
76 Posts
Hi bud, I replied on your other thread,

Have you gone into the factory settings on the unit, password is(normally) 126. From there select canbus tab (iirc) and select alfa romeo from The drop down list of cars. Select apply and exit. Hu should reset and fingers crossed the controls should work.
 

·
Registered
Joined
·
2,888 Posts
Discussion Starter #4 (Edited)
Hi bud, I replied on your other thread,

Have you gone into the factory settings on the unit, password is(normally) 126. From there select canbus tab (iirc) and select alfa romeo from The drop down list of cars. Select apply and exit. Hu should reset and fingers crossed the controls should work.
I did do this, the unit rebooted and then nothing worked not even the volume buttons?
The selection I think said something like Alfa Romeo Bangoo (which happens to be the box fitted) Still did **** all.....
I’m baffled :grumpy:
UPDATE: I now have +/- volume working and the Fwd & Back buttons on the other side but none of the telephone ones???
 

·
Registered
Joined
·
2,921 Posts
If I remember correctly the key wires on head unit harness go to key wires on the patch lead from steering wheel adaptor box.
Key1,key2 and ground. Mine uses the jack plug option but if I remember correctly both key wires need connecting to enable all buttons except mute to work on steering wheel controls.

What wiring kit did you get with your set up,can you post a pic/link?
 

·
Registered
Joined
·
76 Posts
Glad you've got most of the buttons working. Can't really help with the phone buttons. The call buttons on mine don't work either, however since I didn't have b&m factory fitted i didn't use them anyway. So I just use the on screen buttons for calls.
 

·
Registered
Joined
·
155 Posts
Glad you've got most of the buttons working. Can't really help with the phone buttons. The call buttons on mine don't work either, however since I didn't have b&m factory fitted i didn't use them anyway. So I just use the on screen buttons for calls.
Same here all work except for the phone button, not fussed really as dont bother answering calls when driving (Only peace i get these days)
 

·
Registered
Joined
·
2,888 Posts
Discussion Starter #8
I am told that all I need to do is connect the Key2 wire from the head unit harness to the other steering wheel control wire - Where on earth will that be on the plug?
I’m going to have another go tomorrow, I need to find another brown wire allegedly?
 

·
Registered
Joined
·
2,888 Posts
Discussion Starter #9
If I remember correctly the key wires on head unit harness go to key wires on the patch lead from steering wheel adaptor box.
Key1,key2 and ground. Mine uses the jack plug option but if I remember correctly both key wires need connecting to enable all buttons except mute to work on steering wheel controls.

What wiring kit did you get with your set up,can you post a pic/link?
Here you go mate:
https://www.aliexpress.com/item/DSP-Android-8-0-Android-8-1-Car-DVD-GPS-For-Alfa-Romeo-Spider-Alfa-Romeo/32835842025.html?spm=a2g0s.9042311.0.0.68e74c4dHqt2tP
 

Attachments

·
Registered
Joined
·
2,888 Posts
Discussion Starter #11 (Edited)
Topic, what head unit did you get, and if you manage to sort it, would you recommend it?
The one I bought is in the link above but I did go for their all singing all dancing one with DPS, DAB & Rearview camera - yes I would recommend it as it does everything you want plus some.
Easy install except for this little problem but I’m sure I’ll sort this out shortly :rofl:
I may buy their DVR as well for the front?
 

Attachments

·
Registered
Joined
·
2,921 Posts
If I remember correctly the key wires on head unit harness go to key wires on the patch lead from steering wheel adaptor box.
Key1,key2 and ground. Mine uses the jack plug option but if I remember correctly both key wires need connecting to enable all buttons except mute to work on steering wheel controls.

What wiring kit did you get with your set up,can you post a pic/link?
Here you go mate:
https://www.aliexpress.com/item/DSP-Android-8-0-Android-8-1-Car-DVD-GPS-For-Alfa-Romeo-Spider-Alfa-Romeo/32835842025.html?spm=a2g0s.9042311.0.0.68e74c4dHqt2tP
What steering interface have you got one supplied with HU or a different one?
With the patch lead from interface it should only have 3 wires from it and possibly a jack plug. Hopefully it should be a quick fix once you pull HU again
 

·
Registered
Joined
·
2,888 Posts
Discussion Starter #13
What steering interface have you got one supplied with HU or a different one?
With the patch lead from interface it should only have 3 wires from it and possibly a jack plug. Hopefully it should be a quick fix once you pull HU again
The harness sent had Key1 wire already connected within their interface plug, Key2 wire is shown as No.5 in the picture above, this needs connecting/splicing to the other steering wheel control wire. The problem I have is which wire do I need to connect the spare Key2 wire to?
On most cars they only use the Key1 wire, on canbus systems they use both K1 & K2.
 

·
Registered
Joined
·
2,921 Posts
Once you have HU out again hopefully you can tell which one is K2 on the interface,the Chinese HU I tried had all the loom colour coded so would like to think yours would too.
 

·
Registered
Joined
·
2,941 Posts
The harness sent had Key1 wire already connected within their interface plug, Key2 wire is shown as No.5 in the picture above, this needs connecting/splicing to the other steering wheel control wire. The problem I have is which wire do I need to connect the spare Key2 wire to?
On most cars they only use the Key1 wire, on canbus systems they use both K1 & K2.
Different head unit I know Alan, but mine only used one of the key wires
 

·
Registered
Joined
·
2,888 Posts
Discussion Starter #19
yup, but also the HU doesnt shut down after second engine start, needs to press reset button every time. I dont mind about that steering controls, but that annoying reseting every time... ?
Never had that problem?
So if I understand, if you start the car and then turn off ignition HU shuts down normally but if start the car again and switch off it stays on, is that Correct?
 

·
Registered
Joined
·
4 Posts
yup, but also the HU doesnt shut down after second engine start, needs to press reset button every time. I dont mind about that steering controls, but that annoying reseting every time... ?
Never had that problem?
So if I understand, if you start the car and then turn off ignition HU shuts down normally but if start the car again and switch off it stays on, is that Correct?
yes, thats correct.
 
1 - 20 of 174 Posts
Top