Alfa Romeo Forum banner

1 - 8 of 8 Posts
V

·
Guest
Joined
·
0 Posts
Discussion Starter #1
bit of a wierd one

not all the time but sometimes when i accelerate hard in 1st or 2nd at
around 5k revs the handbrake light starts flashing at me only for a second
or two

brakes are fine

just dont know whats up with it?

any ideas
 

·
Registered
Joined
·
46,602 Posts
My handbrake light used to come on at random times , found it was coming on cos the level in the fluid reservoir was low due to the cluth slave clyinder leaking. Dunno if that could be anything related to yours :eek:
 

·
Regional Support, For South Scotland - AOSS
Joined
·
3,507 Posts
Like baby has already hinted at, I had the same on my 156 - fluid level low, this time due to a 'weep' at the connection between one of the pipes and a calliper. Used to flash going up steep hills (like 1:5 steep) too, :)
 

·
Registered
Joined
·
37,341 Posts
Check the wires that go to the front pads are not chaffing on the discs.

If the insulation wears through they will earth on the disc and make the light come on.
 
V

·
Guest
Joined
·
0 Posts
Discussion Starter #6
cheers for the replies guys

the cars going to simply alfa's on tuesday so will get them to check it over and change the fluid
 

·
Registered
Joined
·
4,646 Posts
check the brake fluid level

as the pads wear the fluid level drops.
 

·
Registered
Joined
·
1,369 Posts
mine tends to do this in winter and after making sharp turns at speed.
turns at speed make me think its either the fluid level or the worn cables touching the discs. Its not the fluid level, not looked at cables yet.
 
1 - 8 of 8 Posts
Top