Alfa Romeo Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
80 Posts
Discussion Starter #1
Hey Guys,

Another slight issue has come up over the last few weeks with the GTV.
The handbreak light keeps coming on spiradically usually when foot to the floor.
Is this an indication of anything more than an electrial fault do you think?

Everything else seems normal (well as can be, seen as I need new bushings etc....):rolleyes:
 

·
Regional Support, For Lincolnshire - AOL
Joined
·
16,322 Posts
As bobda says, low fluid level is the most likely cause. This is often caused by a leak in the clutch slave cylinder.
 

·
Registered
Joined
·
684 Posts
I had the same problem, easy fix, there its a cable that runs to the top of the brake fluid reservoir, it is probably loose. Just push it back in and bobs your uncle, it should work.
 

·
Registered
Joined
·
1,055 Posts
same happened to mine. and yes it was a slave cylinder leak. check fluid level and top up then get slave checked if it was. if it goes its a tow job which gets costly.
 

·
Registered
Joined
·
80 Posts
Discussion Starter #6
I do have a slight leak from under the bonet (I notice it on the ground) If your looking straight ahead at the bonet it would be on the left hand side.. under the spotlight! It's not water, looks like some kind of oil

I wonder is this related?

Shoud really get it into Gerry Campell (T.I. Auto's) I suppose
 

·
Regional Support, For Lincolnshire - AOL
Joined
·
16,322 Posts
I THINK that the leak you have noticed is in the wrong location for the Clutch Slave Cylinder.

Here's a pic with some basic locations on, may help you. The Slave cylinder isn't shown but the Reservoir is.

1. Clutch & Brake Fluid Reservoir.
2. Power Steering Fluid Reservoir.
3. Windscreen Washer Fluid Reservoir. ( This may seem a bit " noddy " but new owners might not have had to find this yet ! )

Hope you can resolve the problem, my cash is still on a leaky Slave Cylinder and if it does get worse the Clutch pedal sticks down when you use it. Still useable but a right pain that could actually be dangerous.

http://www.alfaowner.com/Forum/attachment.php?attachmentid=67642&stc=1&d=1244043755
 

Attachments

·
Registered
Joined
·
318 Posts
I had this before and it was the slave cylinder, not to expensive to fix,
could it also be the hadbrake button thats sticking when down so its boncing about ??I have noticed mine sticks a little now & then
 

·
Regional Support, For Lincolnshire - AOL
Joined
·
16,322 Posts
I had this before and it was the slave cylinder, not to expensive to fix,
could it also be the hadbrake button thats sticking when down so its boncing about ??I have noticed mine sticks a little now & then
More likely to be a sticking float in the reservoir.

Could also be the switch under the handbrake lever that is dirty/sticky, a problem I had with mine.
 

·
Registered
Joined
·
1,055 Posts
Just keep an eye on it. If it happens again soon it's gonna be a leak
 

·
Registered
Joined
·
2,142 Posts
Note that the level falls in the reservoir as the pads wear - if they are worn this could be the reason and now that it is topped up it may overflow (not good!!) when the pistons are pushed in to fit new pads. but as said, keep an eye on it - if it falls perceptibly then its a leak.

A leak under the o/s foglight is the oil cooler on a V6, not sure where it is on a TS. V common fault due to rusting of steel (Alfa cheapskates) oil pipes. Needs attention straightaway & unfortunately not v cheap or easy ... see other threads.
 
1 - 12 of 12 Posts
Top