Alfa Romeo Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Hey guys! I have a 98'gtv v6 tb that's been acting a bit wierd lately. When i push down the pedal and start acceleration it stutters and cuts off and on until I release the pedal, upon pushing the pedal slightly down it runs more smooth, but still choking, like something is holding it back.

After driving a while it becomes slightly better, and at a point it stops completely, and the car is back to normal. If I park it and drive it later in the evening everything is still fine. But if the car is parked for a day it's back to stuttering and the cycle continues. I don't know what it can be... I can't find any leakage in the hoses,the air filter is new, the spark plugs and leads are new. And the fuel filter is brand new. Any suggestions??? apologies if my explanation isn't that great, English is not my primary language.
 

·
Registered
Joined
·
2,964 Posts
is the car fitted with a EGR valve would be a part at the back right of the Plenum ??? not all cars were fitted

either that or the MAF as already stated
 

·
Registered
Joined
·
270 Posts
1. Check that the throttle body butterfly is opening properly and not a jerky motion, a helper is necessary to modulate the accelerator. Clean carefully with carb cleaner then a very light spray of WD-40 on the brass spindle ends. Repeat the check.

2. Remove the sensor from the MAF body spray a small amount of window cleaner on a cotton bud and clean the angled mirror gently. Dry with clean cotton buds. Spray the wire, resistor and the two open square holes with iso-propyl alcohol spray. Allow to dissipate, refit and reconnect the multi plug.

3. Investigate why both became dirty in the first place, always a cause to a problem! Usually a badly fitted lid to the air filter housing allowing unfiltered air to seep into the system coating the MAF sensor with road film.

4. Run the car to see if things improve. If they do invest in a new air filter, housing and have a cuppa and marvel at the money you just saved.

5. If no improvement is apparent, chances are the MAF is beyond help or a potential issue with the potentiometer on either the throttle pedal or the throttle body tracking rails inside the black plastic. Good used ones are fine but strip the old one and clean out the tracks and use as a spare in the future.

Job done and usually items 1-3 do the trick for no more than £12 tops!
 

·
Registered
Joined
·
270 Posts
Just a further bit of info.
Check your intake hoses for any splits causing a discrepancy between what the MAF measures and what the manifold meters.

Check the possibility of your oil union from the turbo bearing leaking droplets of oil into the compression side via the bearing seals behind the compressor blades. Easily checked once you remove the hose towards the intercooler from the turbo housing. If it has oil and grime then their is your culprit. With compressed air flow the oil vapours will travel through the intercooler all the way up to throttle body coating it in a fine film over time. Grime sticks and prevents the butterfly from moving properly. Once those vapours get into the intake system it coats everything including the MAF sensor resistor wire eventually.
In short, just make sure the entire intake system is clean, sealed and healthy, check every service period and you'll get no bother.
 

·
Registered
Joined
·
1,164 Posts
No MAF on the GTV turbo, it's an AFM.

Throttle body butterfly is controlled by a gas pedal cable not with a fly by wire control of the butterfly.

- Try to reduce the spark plug gap to somewhere between 0.6 - 0.65 mm.

- Check the distributor cap so that it is healthy.

- Check pierburg valve and hoses to it so that there are no problems there.

- Check that the sheet metal in the AFM intake is in place and has not been removed.
 

Attachments

·
Registered
Joined
·
8 Posts
Discussion Starter · #7 ·
Thanks GTV Tb! I think I know what the problem is now.. Check my pic, am I on to something? It seems damaged, can't get a smooth connection due to the damage. It's a bit dark, but ull see the bottom part is broken, what do u reckon?
 

Attachments

·
Registered
Joined
·
1,164 Posts
Yeah, they all do that through time, it's an weak construction and the glue used by Alfa to glue the plastic tube and metal plate together are just disappearing as time goes by.

Clean off the plastic tube and metal plate with paint thinner .. straighten up plastic tube against the metal plate and glue them together with this .. Stål-Epoxi - Lim Stål-Epoxy Epoxy Järnepoxy - Biltema ..that's the only glue of all the glues I've tested that works ..I don't think that the deformed AFM air intake are the only problem, also try to reduce gap on the spark plugs and see what happens, what spark plugs do you use?
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #9 ·
I went to biltema and got the glue of all glues! Managed to fix the intake, car runs better, but yes this is not the only problem. I can still feel something slightly choking the car when I accelerate. I'll check out what spark plugs I got tomorrow, I actually just bought the car a few weeks ago in Oslo, so I don't know it that well yet. But the stuttering came after purchase, around the time I did some light maintenance, like changing air filter, oil refill, cleaning engine etc. At first I thought it was the new air filter but I put on the old one again and alas same stuff..
 

·
Registered
Joined
·
1,164 Posts
Cleaning the engine :yikes::titanic: .... have you checked so that you don't have moisture inside the distributor cap and down in the spark plug wells?
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #11 ·
No I didn't use any water, by cleaning I mean dusting, just a dry cloth. Freshen the paint on the logos etc.. I don't wanna **** it all up with a bunch of water haha, done that mistake before :)
 

·
Registered
Joined
·
152 Posts
It sounds like a problem I had...My fuel pump "jammed" from time to time...Try and listen to wen your car starts to stutter or die for the fuel pump. mine usually made a noise like sucking on a empty tank and a loud wine.
 
1 - 13 of 13 Posts
Top