Alfa Romeo Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
416 Posts
Discussion Starter #1
I have searched the forum but could not find specific to my search. The temp sits perfectly at all times except when I'm doing motorway, in which case it rests just in the middle of the first half on meter. Is this normal or thermostat issue?

Thanks
 

·
Registered
Joined
·
780 Posts
I have searched the forum but could not find specific to my search. The temp sits perfectly at all times except when I'm doing motorway, in which case it rests just in the middle of the first half on meter. Is this normal or thermostat issue?

Thanks
I assume you mean it sits between 50*c and 90*c?

That sounds about right iirc. During traffic it should get to around 90*c and the fan may need to kick in occasionally to cool it down but otherwise, on the motorway, your temp reading sounds about right provided the ambient temps aren't exorbitant (which being the UK they aren't :p )
 

·
Registered
Joined
·
416 Posts
Discussion Starter #4
I assume you mean it sits between 50*c and 90*c?

That sounds about right iirc. During traffic it should get to around 90*c and the fan may need to kick in occasionally to cool it down but otherwise, on the motorway, your temp reading sounds about right provided the ambient temps aren't exorbitant (which being the UK they aren't :p )
Yes it sits between 50 and 90 - couldn't remember the lower value :). Thanks for replying. Just the answer I was looking for.
 

·
Registered
Joined
·
174 Posts
Definitely normal, I had a new thermostat 2 months ago and this is exactly what mine now does, happily.
 
1 - 6 of 6 Posts
Top