Alfa Romeo Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
80 Posts
Discussion Starter #1
Hi Guys,

Just a quick thing thats been driving me crazy over the last month or so...
Whenever I put my foot on the clutch or even barely hover over it the car sounds electric
(as in a high pitched whirring noise appears to come from the engine).
The car has been serviced recently but other than that nothing appears unusual.

Anyone got any idea's what it may be?:confused:

Thanks
 

·
Registered
Joined
·
80 Posts
Discussion Starter #5
Gearbox/Clutch
I'd been having problems with the differential between gears
eg.. sh'es kangaroo jumping a little from 2nd -> 3rd -> 4th.
Would this having anything to do with the release bearing?

Radio
On another note: I took my radio unit out today to fix the antenna
and the heat sink at the back of the Sony unit was absolutely roasting!
Too hot to hold for longer than 2 seconds. Is that normal?
The radio had been on for a few hours at this stage!

:rolleyes:
 

·
Registered
Joined
·
109 Posts
mine makes this noise when changing gear. My clutch feels great though, its light with the bite point in the middle
 

·
Registered
Joined
·
80 Posts
Discussion Starter #7
Yeah mines pretty light too! But the noise is sooo irritating!
Gonna drop her over to the garage later and will keep ya posted!;)
 

·
Registered
Joined
·
109 Posts
Yeah mines pretty light too! But the noise is sooo irritating!
Gonna drop her over to the garage later and will keep ya posted!;)
i spoke to someone and says it does not affect the clutch and ok if you dont mind the noise. Stereo on i hear nothing so not too worried
 

·
Administrator
Joined
·
23,083 Posts
It is almost certainly the release bearing. The noise got so bad at 46k miles that I changed the complete clutch (always worth doing). I am now up to 137k miles and the noise is beginning to start again - but I guess 90k on the same clutch is not too bad. I'll leave it until it becomes unbearable and, hopefully, before it seizes.
 

·
Registered
Joined
·
80 Posts
Discussion Starter #11
He was also telling me about a 147 that he's servicing that has 240,000km's with all original parts! ... imagine that!:rolleyes:
 
1 - 15 of 15 Posts
Top