Alfa Romeo Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
84 Posts
Discussion Starter #1
Hi People

My beloved GTV has a problem. The near side rear wheel is leaning inwards slightly. This with a whine from the rear at speed is making me think wheel bearing? Just thought I'd ask here what you think as I'm new to Alfa's? Any advise welcomed.

Cheers
Mark
 

·
Registered
Joined
·
84 Posts
Discussion Starter #4
It's leaning quite a bit, visibly more than than the drivers side... tire place said they can't do wheel alignment until I sort the back wheel...
 

·
Registered
Joined
·
84 Posts
Discussion Starter #8
Thanks guys I'll have to have the wheel off and have a good look tomorrow... The whining starts around 60mph or above... I thought it might be the wheel bearing? Been driving it like it for a while now Doh!
 

·
Registered
Joined
·
7,768 Posts
Does it disappear at all when you turn left or right at this speed? mind, i wouldn't be trying it without checking your suspension 1st.
 

·
Registered
Joined
·
13,233 Posts
That whine is the wheel bearing but the camber problem sounds like a collapsed bush or ball-joint etc.

The bearing obviously doesn't like the unusual extra pressure it's being beaten with...

The main thing is to make sure your sub-frame isn't being damaged (aluminium extrusion the size of bed... how much do you think one of those costs.. :eek: ) but what's broken will need a wheel off and a root about.


Ralf S.
 

·
Registered
Joined
·
84 Posts
Discussion Starter #12
I thought I'd better say what the problem was... Might help another numpty like me sometime...

First of all thanks guys for all your advice... It was a knackered inner bush on the dog leg arm the one at the subframe (lucky no subframe damage). It was making the bottom of the wheel step out more hence the weird camber... Got replacement part from Autolusso and problem sorted... Back to driving with a big grin...

Thanks again
 
1 - 12 of 12 Posts
Top