Alfa Romeo Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
334 Posts
Discussion Starter #1
hello guys, when i turn on my radio (97'GTV -Clarion) it has no sound and it only displays the numbers "1245" does anybody know what the radio problem is?
 

·
Registered
Joined
·
111 Posts
Sounds like the wrong code has been entered for some reason.

From the service manual:

If the (secret code) number is wrong the number stays on the display; press the band button for at least 3 seconds and enter the correct number.

Note: After three incorrect entries the radio will remain blocked for one hour; after a subsequent attempt it will be necessary to wait a further hour


So wait an hour since your last attempt to enter the code and give it another go, following the instructions above.

If you haven't got the Clarion code card you may have to contact an In-car Audio specialist.

If that fails, just listen to the engine ... it's better than any music anyway :p

Good luck,

Blakie
 

·
Registered
Joined
·
334 Posts
Discussion Starter #4
blakie: yup the engine sounds better anyway! the h.u is crap!..i have the code numbers but can't even input them!.. i think the h.u. is dead! haha need a new one! but i think i need a radio face adaptor? right?
 

·
Registered
Joined
·
343 Posts
The aperture is the same as most replacement HU's being straight forward DIN. The plugs on the rear are fairly universal so an adpater for approx a fiver should sort that no probs if plugs are different. I found they are the same as on a Vauxhall and a Ford I once had many moons ago. RE facia, not sure whether its a differnet shape to the standard 2.0 ts but the only prob would be the facia is a different shape and won't look so smooth, however with the aperture being the same a replacement should go straight in. It shouldn't be like some new radios on vehicles eg 147 that have a double DIN aperture that needs something to reduce the size, thus making it less secure. (Unless you get a head unit that is double DIN). (Please correct me if wrong as I'd like to know).

Hope this helps,
BGTV
 

·
Registered
Joined
·
334 Posts
Discussion Starter #7
BenGTV: yup it's a 1-din h.u. .. i think it's a straight swap to other h.u.'s but the nice engine sound makes having a radio negligible.. hehe
 

·
Registered
Joined
·
334 Posts
Discussion Starter #9
yahoo! aftrer months of no radio finally got my radio to work! pressed the "sel" button
for a longggg time then it made the "input code" display! and finally have radio in my car BUT it still sounds like crap!
 
1 - 9 of 9 Posts
Top