Alfa Romeo Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter #1
Hi there guys

As an owner of various alfa's over the years and one GTV prior to my current one I'm fully aware our motors are susceptible to little electrical gremlins and to some extent we have to put up with it. However I suspect there's a very simple answer to my cars central locking issue, can anyone help?

Its a 54 plate JTS I've owned it about 18 months, very fond of it. In summer I don't tend to have issues with the locking system, I just aim the key fob at it and it locks and unlocks as it should. In winter however the car still seems to open up ok with the key fob, put perhaps 70% of the time I have to lock it with the key, the lights flash when I aim the keyfob at it but it doesn't lock. As I say 30% of the time it will work. Strange.

I can actualy live with this but its not ideal so any suggestions gratefully accepted.
Cheers:confused:
 

·
Registered
Joined
·
4,301 Posts
Hi,
The locks freeze in the winter on these cars and there's no quick fix I'm afraid, I don't use my car over the winter months so can't really give you advice but I have had the same problem and know it to be common.

Edit: Just re read your post and realised I miss under stud what you were talking about! :lol:

You could always try a new battery in the key fob.
New key fob it self.
Try an Alarm specialist, maybe able to shed some light on the subject.
 

·
Registered
Joined
·
39 Posts
Discussion Starter #6
Thanks guys,

Jimmy Coupe, I have a feeling its a different indicator flash. Yesterday when I'd got back in it the hazards were flashing as I was driving so I had to stop, restart and then it was ok. This happened once or twice before in the past year and is what prompted my post.

Having read your question I just went out to check. Quite perversely it has just opened and locked exactly as it should 4 times in a row. That has not happened in a long time.

Very odd.
 

·
Registered
Joined
·
236 Posts
If it helps a different indicator flash tells you that something isnt shut properly. I'm still quite new to the Alfa GTV but things like bonnets not being full locked on both sides can cause funny behaviour with the fob/ alarm arming so maybe worth checking that everything is shut. I believe even the fuel door is electronic so check everything.

Odd they started flashing when you were driving, kind of sounds like the alarm was still armed and went off whilst driving without the siren???

Have you ever heard your alarm siren sound?

I have an alarm issue at the moment which is stopping me locking the car with the fob. I have located it to the bonnet, as one of the sides keeps popping open and triggering the alarm. Obviously locking by the key isnt arming the alarm, just the immobiliser. Mine only started playing up in the winter as well, I think its the winter wind whipping the bonnet up slightly.

PS I'm not sure if you know but the car will still start with the alarm still armed or going off :lol: funny old Alfa's :).
 

·
Registered
Joined
·
39 Posts
Discussion Starter #9
No, locks have never bounced around on this one, they did on my phase 2 GTV. Seems ok today, going to put it down to the weather for now I think. Thank you for your replies.
 
1 - 9 of 9 Posts
Top