Alfa Romeo Forum banner

1 - 4 of 4 Posts
N

·
Guest
Joined
·
0 Posts
Discussion Starter #1 (Edited)
As the title suggests I have seem to have a squeaky alternator. It's my own diagnosis using a length of tube to locate the noise.

A couple of months ago I had the cam belt, tensioners, etc replaced along with the water pump (hence i don't believe it's these). The garage used all of the locking tools, so a good job!! He told me that the aux belt, tensioner and pulley also could do with replacing. Being a semi-keen home mechanic i have changed all of these bits myself.

However....... there is something on the aux belt system that is still causing a sqeak and i seem to have narrowed it down to the alternator (rear lower pulley). If i back the tension off the belt slightly using a spanner on the tensioner it goes away. Likewise if i drive for a bit it goes away.

My question is can i replace just the pulley to stop the squeak, as the alternator charges and seems to be working ok electrically or is it a duff tensioner?? I have heard the alternator replace is a 'mare.
 
N

·
Guest
Joined
·
0 Posts
Discussion Starter #2
Also realised that since fitting the front component speakers with passive crossovers I have a rev dependant electrical humm through one side. Is this, as well as the sqeak, leaning towards my alternator may be on it's way out?
 
N

·
Guest
Joined
·
0 Posts
Discussion Starter #3
anyone got any ideas? or places to get a cheap one of the internet?

I think i may have a go at replacing it. Would like to remove the idea it may be the tensioner though.:(
 

·
Registered
Joined
·
989 Posts
Yeah, squeaking/squeal is the first sign, especially after an aux belt change which will mean the belt will have no slack in it. Mine siezed, which stalls the engine.

Exchange/ Replacement is the solution, I should warn you it is a PIG of a job. Cost me £300 all in from A4A :)
 
1 - 4 of 4 Posts
Top