Alfa Romeo Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
269 Posts
Discussion Starter #1
garage today found these codes.

03 connection between lamp and ECU, fail.

05 passenger Air Bag off lamp.

I have the diagnostic software now set up on an old laptop.
Its not a straightforward thing at all, a real *****, can't get the bit to open for the DTC although it seems to scan.
It didn't detect any fault codes when i went in on my laptop and yet today the garage found 2 fault codes.

The local garage kind of doesn't want to know but will do the scan. Tell me the fault codes.

Ironically never had any trouble like this with my Alfa 147.
 

·
Registered
Joined
·
422 Posts
The airbag system can be a problem. Best not adjust seats with ignition on, if you are taking seats out then makes sure battery is disconnected until seats back in. Sometimes can't switch airbag light off just have get new airbag ecu.... Be very careful if it's working then don't fix it.......
 

·
Registered
Joined
·
5,327 Posts
When you look at the codes for the air bags in the 916 be aware that although it might come up as passenger side it really means driver side. The codes are set up for left-hand drive! Also have a look at the pre-tensioners, the plastic cover comes off easily and look to see if the connection is still firm. I triggered the light when tucking in some seat covers next to the pre-tensioner. Said it was passenger side but it was the driver's side. Reset using FiatEcuScan as it as called then, and it was the basic one too.
 

·
Registered
Joined
·
269 Posts
Discussion Starter #4
"Phase3dude, post:
"Sometimes can't switch airbag light off just have get new airbag ecu.... "

Wondering then if the Air Bag ECU is faulty causing the 03 fault?
 

·
Registered
Joined
·
269 Posts
Discussion Starter #6
Your not certain?
Certain is needed here?

Somebody has to have been down this path one would think.
 
1 - 7 of 7 Posts
Top