Alfa Romeo Forum banner

1 - 20 of 26 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
I've just changed all 4 disks and pads on my GT and now the ABS and VDC lights have come on, I've checked the front wheel sensors and they all seem fine.
I took it for a test drive and it drives fine, I did noticed the ASR off control switch is lit as well.
I'm now stuck for answers, help.

Thanks in advance people.
 

·
Registered
Joined
·
1,928 Posts
its deffo a damged sensor or wire......i bust my front passenger one while changing hub and had exactly the same prob
simply gotta new sensor from euro car parts

the sensors on pads dont affect the abs system do they????????????
 

·
Registered
Joined
·
28 Posts
Discussion Starter #4
Cheers, I don't think they do.
Having no manual, I just pushed the rear pads back, disaster possibly???
Not sure
:-/
 

·
Registered
Joined
·
9,912 Posts
foot brake switch!

hold on a minute what did you do to car prior to this fault coming up? replacing brakes shouldnt give a fault unless youve cracked the sensor or wiring for abs more so on rears
 

·
Registered
Joined
·
28 Posts
Discussion Starter #10
Having looked at the rears it looks like the o/s sensor has been rubbing with the hub, I've cleared the gap of the dirt but I think this has been going in for some time as the hub section is smooth, not castellated like the others.
I reckon the sensor needs replacing after what you have all said.
Thanks for the help so far.
 

·
Registered
Joined
·
1,928 Posts
the lights will go out when u drive a short distance if cleaning it as worked......they will still be on if u turn ignition on while car is parked up
it may at worst case need a sensor and bearing

have u been for a run since cleaning?
 

·
Registered
Joined
·
9,912 Posts
Having looked at the rears it looks like the o/s sensor has been rubbing with the hub, I've cleared the gap of the dirt but I think this has been going in for some time as the hub section is smooth, not castellated like the others.
I reckon the sensor needs replacing after what you have all said.
Thanks for the help so far.
GET YOUR CODES READ :thumbs:
 

·
Registered
Joined
·
28 Posts
Discussion Starter #13
Dave, mate, steady on, it's Sunday, I live on the edge of nowhere and there is no one close to do it.
I have taken it out and they stay on, I'm going to pick up a new sensor in the week and try again on Sunday.
 

·
Registered
Joined
·
9,912 Posts
Dave, mate, steady on, it's Sunday, I live on the edge of nowhere and there is no one close to do it.
I have taken it out and they stay on, I'm going to pick up a new sensor in the week and try again on Sunday.
you could end up chasing your tail...........
 

·
Registered
Joined
·
120 Posts
I Live near Ramsgate and work in Canterbury.

I have a free version of Fiat ECU Scan, and a cable. So if your stuck and up this neck of the woods. Drop me a message and we'll see what we can do.

Cheers

Dom
 

·
Registered
Joined
·
28 Posts
Discussion Starter #19
I found on the forum a place called Mobitech in Canterbury, I'm going to get them to read it tomorrow and then let's see eh??
 
1 - 20 of 26 Posts
Top